Media (Intel® Video Processing Library, Intel Media SDK)
Access community support with transcoding, decoding, and encoding in applications using media tools like Intel® oneAPI Video Processing Library and Intel® Media SDK
Announcements
The Intel Media SDK project is no longer active. For continued support and access to new features, Intel Media SDK users are encouraged to read the transition guide on upgrading from Intel® Media SDK to Intel® Video Processing Library (VPL), and to move to VPL as soon as possible.
For more information, see the VPL website.

Encoding VPP feature

Celio_A_
Beginner
514 Views

Hi, i need help in adding to sample_multi_transcode VPP 10bit (P010) conversion because working VPP feature on sample_decode is working but need too much space on disk and  i preffer pay a developer to add this feature and dont upgrade server disks, can u help me?

In the latest driver version VPP (P010) conversion its working with hardware implementation, what i need is a conversion like sample_decode have, i think its possible right? If sample_decode Works i think sample_multi_transcode can be added

Regards

 

 

0 Kudos
4 Replies
Mark_L_Intel1
Moderator
514 Views

Hi Celio,

If you look at the following code, we might already have it. Could you confirm by running this code?

https://github.com/Intel-Media-SDK/MediaSDK/blob/master/samples/sample_multi_transcode/src/transcode_utils.cpp#L274

Basically, VPP itself should not care about 8 bits or 10 bits.

Mark

0 Kudos
Celio_A_
Beginner
514 Views

Yes i know for software hevc encoding but for hardware encoding it always return not supported when u add -ec::p010 to comand line

0 Kudos
Mark_L_Intel1
Moderator
514 Views

Hi Celio,

Could you give me your environment so I could try it?

Based on our latest code, we never report "no support" in our recent sample, see the following code:

https://github.com/Intel-Media-SDK/MediaSDK/blob/master/samples/sample_multi_transcode/src/vpp_ext_buffers_storage.cpp#L260

It doesn't check for HW or SW either.

Mark

0 Kudos
Celio_A_
Beginner
514 Views

Here is my encoding command line 

D:\Intel Media SDK Plugins>sample_multi_transcode -i::h264 D:\Source.264 -o::h265 D:\Teste.hevc -hw -async 10 -pe e5400a06c74d41f5b12d430bbaa23d0b -b 7500 -vbr -MaxKbps 22000 -u balanced -l 1 -gop_size 24 -dist 4 -num_ref 6 -bref -bpyr -dc::nv12 -ec::p010 -w 1920 -h 1080 -WeightedPred::implicit -WeightedBiPred::implicit -amfs:on -extbrc::implicit -CodecLevel 2 -pp
Multi Transcoding Sample Version 8.3.26.0
 
External allocator will be used as some cmd line paremeters request it.
Session 0:
Preset-controlled parameters (Default):
RateControlMethod: 2 (original preset value: 2)
AdaptiveMaxFrameSize: 16 (original preset value: 0)
AsyncDepth: 10 (original preset value: 4)
BRefType: 2 (original preset value: 0)
EnableBPyramid: 1 (original preset value: 0)
GopRefDist: 4 (original preset value: 0)
IntRefCycleDist: 0
IntRefCycleSize: 0
IntRefQPDelta: 0
IntRefType: 0
LowDelayBRC: 0
TargetUsage: 4 (original preset value: 4)
WeightedBiPred: 3 (original preset value: 0)
WeightedPred: 3 (original preset value: 0)
GopPicSize: 24 (original preset value: 47)
MaxKbps: 22000 (original preset value: 0)
TargetKbps: 7500 (original preset value: 2748)
BufferSizeInKB: 7500
MaxFrameSize: 0
LookAheadDepth: 0
 
plugin_loader.h :173 [INFO] Plugin was loaded from GUID: { 0xe5, 0x40, 0x0a, 0x06, 0xc7, 0x4d, 0x41, 0xf5, 0xb1, 0x2d, 0x43, 0x0b, 0xba, 0xa2, 0x3d, 0x0b } (Intel (R) Media SDK GPU-Accelerated plugin for HEVC ENCODE)
Pipeline surfaces number (EncPool): 19
Pipeline surfaces number (DecPool): 15
 
[ERROR], sts=MFX_ERR_INVALID_VIDEO_PARAM(-15), TranscodingSample::CTranscodingPipeline::Init, m_pmfxVPP->Init failed at c:\users\administrador.win-8jv6l7361jn\documents\intel media sdk 2018 r1 samples\sample_multi_transcode\src\pipeline_transcode.cpp:3688
 
[ERROR], sts=MFX_ERR_INVALID_VIDEO_PARAM(-15), TranscodingSample::Launcher::Init, pThreadPipeline->pPipeline->Init failed at c:\users\administrador.win-8jv6l7361jn\documents\intel media sdk 2018 r1 samples\sample_multi_transcode\src\sample_multi_transcode.cpp:353
plugin_loader.h :199 [INFO] MFXBaseUSER_UnLoad(session=0x000001E604F9E000), sts=0
 
[ERROR], sts=MFX_ERR_INVALID_VIDEO_PARAM(-15), wmain, transcode.Init failed at c:\users\administrador.win-8jv6l7361jn\documents\intel media sdk 2018 r1 samples\sample_multi_transcode\src\sample_multi_transcode.cpp:913
 
If i remove the command line option -ec::p010 it works but only 8 bit
0 Kudos
Reply