Media (Intel® Video Processing Library, Intel Media SDK)
Access community support with transcoding, decoding, and encoding in applications using media tools like Intel® oneAPI Video Processing Library and Intel® Media SDK
Announcements
The Intel Media SDK project is no longer active. For continued support and access to new features, Intel Media SDK users are encouraged to read the transition guide on upgrading from Intel® Media SDK to Intel® Video Processing Library (VPL), and to move to VPL as soon as possible.
For more information, see the VPL website.

HW Decoder Init Fails

lizardking
Beginner
420 Views
Hi All,
I am trying to stream some video files using the Darwin Streaming Server and Live555 Library.

I tried streaming 6 video files(MPEG2 Decoder) of resoultion 1280*720. The streaming works fine without any packet loss. I render the recieved data concurrently. After few successfull loop-playbacks, one of the video window stops rendering.
This happensonlywhenI try to run it onH/W.
On debuggingI found that the Decoder Init fails, returning MFX_ERR_UNSUPPORTED.
This occurence is very random.

Further I added the following lines of codeimmediately after Init is called.
if( sts == MFX_ERR_UNSUPPORTED)
{
//call Init Again
}
And Voila! It succeeds.

My setup configuration is :
OS - Windows 7(64 bit)
Target Architecture - x64
Discrete Graphic Card - None
Hardware - Sandy Bridge (i7)

Any idea why does it fail?
And why it succeeds on passing the same parameters with which it failed?
0 Kudos
1 Reply
Petter_L_Intel
Employee
420 Views
Hi,

You indicate that you receiveMFX_ERR_UNSUPPORTEDwhen calling Decode Init. So this issue is only seen when initializing the decoding session? I would guess that the reason is that DecodeHeader did not parse the stream header correctly, possibly due to corrupted data from the streaming component.

Could you please provide a log using Media SDK tracer tool (with frame based logging enabled). It may help understand what the reason for failed Decode Init.

Can you please also provide the gfx driver verison you are using.

Regards,
Petter
0 Kudos
Reply