Media (Intel® Video Processing Library, Intel Media SDK)
Access community support with transcoding, decoding, and encoding in applications using media tools like Intel® oneAPI Video Processing Library and Intel® Media SDK
Announcements
The Intel Media SDK project is no longer active. For continued support and access to new features, Intel Media SDK users are encouraged to read the transition guide on upgrading from Intel® Media SDK to Intel® Video Processing Library (VPL), and to move to VPL as soon as possible.
For more information, see the VPL website.

Image corruption in HEVC software decode plug-in

Masa-Tam
Novice
1,227 Views

The prerequisites are quite strict, but it can happen when the following conditions are met.

If you decode two HEVC videos of 3840x2160 Main 4:2:2 10bit Intra Profile from a single app in a multi-threaded manner at the same time, a band with Y = 0 / U = 0 / V = 0 may occur at the bottom of one of the videos.
The rate of occurrence varies depending on the environment and stream, and it is not a certainty, but even in the worst case, it occurs after 10,000 attempts.

Labels (1)
0 Kudos
1 Solution
Masa-Tam
Novice
1,112 Views

I am very sorry. It was a problem with my code.

It seems that the CPU was making the timeout time too tight, and if the decoding didn't complete within 1 second, it would stop and fetch the image.
This caused a green band at the bottom of the screen, depending on the CPU and start-up timing.
This phenomenon has been resolved by extending the timeout time considerably.

View solution in original post

0 Kudos
4 Replies
JesusE_Intel
Moderator
1,194 Views

Hi Masa-Tam,


Thanks for reaching out, I understand the issue is not persistent. Could you please provide us as many details as you can about your environment to help us reproduce?


  • Software versions
  • OS Version
  • System details


Regards,

Jesus




0 Kudos
Masa-Tam
Novice
1,171 Views

Software version: 2019 R1

OS: Windows 10 Pro x64

Afterwards, I conducted a follow-up test and found that the probability of breaking differs depending on the CPU.

on i7 4770 CPU:

Breakage often occurs in the first video. The breakage is always at the bottom of the screen, and since the data is filled with 00s, it will be displayed as a green band when converted to RGB.

on i7 6700K CPU:

Most of the time the corruption doesn't occur, but if it does, it occurs in the first video.
Likewise, the corruption is always at the bottom of the screen.

0 Kudos
JesusE_Intel
Moderator
1,152 Views

Hi Masa-Tam,


Thank you for providing the additional information. Do you run into the same issue on the latest Intel MediaSDK 2020 R1 release? If the issue is still present please provide the steps, command, input file and sample code to reproduce.


Regards,

Jesus


0 Kudos
Masa-Tam
Novice
1,113 Views

I am very sorry. It was a problem with my code.

It seems that the CPU was making the timeout time too tight, and if the decoding didn't complete within 1 second, it would stop and fetch the image.
This caused a green band at the bottom of the screen, depending on the CPU and start-up timing.
This phenomenon has been resolved by extending the timeout time considerably.

0 Kudos
Reply