Media (Intel® Video Processing Library, Intel Media SDK)
Access community support with transcoding, decoding, and encoding in applications using media tools like Intel® oneAPI Video Processing Library and Intel® Media SDK
Announcements
The Intel Media SDK project is no longer active. For continued support and access to new features, Intel Media SDK users are encouraged to read the transition guide on upgrading from Intel® Media SDK to Intel® Video Processing Library (VPL), and to move to VPL as soon as possible.
For more information, see the VPL website.
3060 Discussions

Intel GPU decode H264 Stream Fail But FFmpeg decode OK

CBill2
Beginner
434 Views

Hi I have a problem,

When I using Intel GPU decode H264 stream it always return fail, But it is OK when using FFmpeg decode.

I have updated two streams, one it can decode sucessfully by FFmpeg and Intel GPU, the other one it can only decode sucessfully on FFmpeg.

My computer system is "Intel Core i5-4590 CPU 8G ram , windows 8.1"

Intel_GPU_Decode_Fail_FFmpeg_Decode_OK.264 => Intel GPU decode Fail, FFmpeg decode OK

Intel_GPU_Decode_OK_FFmpeg_Decode_OK.264 => Intel GPU decode OK, FFmpeg decode OK

thank you for your help,

Bill

0 Kudos
4 Replies
Mark_L_Intel1
Moderator
434 Views

Hi Bill,

Could you increase the size of the file to 2MB and try again? I guess your file size is too small.

Mark

0 Kudos
CBill2
Beginner
434 Views

Hi Mark,

I think it is not the point of the file's size, I have increased 2MB size of file, but Intel GPU still decode fail.

thank your help 

Bill

0 Kudos
Mark_L_Intel1
Moderator
434 Views

Yes, this is not the file issue.

This is what we knew:

DecodeFrameAsync() returns MFX_WRN_VIDEO_PARAM_CHANGED 6 times (after each call it consumes part of loaded bitstream) and does not return syncPoint.

After 7th call it returns MFX_ERR_MORE_DATA (because stream data is finished, there's only 3 bytes left). Sample tries to load data from file, but there's no more data.

 

So this is more likely the decoder issue when parsing the data, a bug was submitted. I will update the status when there is a result.

 

Mark

0 Kudos
Mark_L_Intel1
Moderator
434 Views

Hi Bill,

The file has the following issues:

The value of [SliceHeader :: idr_pic_id = 65592] exeeds maximum allowed by spec.
ITU-T H.264 <7.4.3 Slice header semantics> says:
The value of idr_pic_id shall be in the range of 0 to 65535, inclusive.
Decoder waits incoming IDR to start decoding but all of these IDRs are affected by the same error and skipped as invalid

Does this solved your problem?

Mark

0 Kudos
Reply