Media (Intel® Video Processing Library, Intel Media SDK)
Access community support with transcoding, decoding, and encoding in applications using media tools like Intel® oneAPI Video Processing Library and Intel® Media SDK
The Intel Media SDK project is no longer active. For continued support and access to new features, Intel Media SDK users are encouraged to read the transition guide on upgrading from Intel® Media SDK to Intel® Video Processing Library (VPL), and to move to VPL as soon as possible.
For more information, see the VPL website.

Intel Gfx driver is not found

New Contributor I



I'd like to decode RTP H.264 video stream received from Network camera.

But installation of Media SDK failed. 


Downloaded libva, libva-utils, Gmmlib, media-driver, and MediaSDK from Github.

Build by gcc 8.3.1 (devtoolset-8)and installed.






     Media SDK and Samples:


# vainfo

     error: XDG_RUNTIME_DIR not set in the environment.
     error: can't connect to X server!
     libva info: VA-API version 1.7.0
     libva info: User environment variable requested driver 'iHD'
     libva info: Trying to open /usr/local/lib/dri/
     libva info: Found init function __vaDriverInit_1_7
     DRM_IOCTL_I915_GEM_APERTURE failed: Invalid argument
     Assuming 131072kB available aperture size.
     May lead to reduced performance or incorrect rendering.
     get chip id failed: -1 [22]
    param: 4, val: 0
    libva error: /usr/local/lib/dri/ init failed
    libva info: va_openDriver() returns 18
    vaInitialize failed with error code 18 (invalid parameter),exit


I added option "--display drm --device /dev/dri/renderD129", but it was same error message.


I made following initialize code.  But the device file is not found.

int open_intel_adapter()
std::string adapterPath = "/dev/dri/renderD";

char driverName[5] = {};
mfxU32 nodeIndex = 128;

for (mfxU32 i = 0; i < 16; ++i) {
std::string curAdapterPath = adapterPath + std::to_string(nodeIndex + i);

int fd = open(curAdapterPath.c_str(), O_RDWR);
if (fd < 0) continue;

drm_version_t version = {};
version.name_len = 32; = driverName;
ioctl(fd, DRM_IOWR(0, drm_version), &version);
if(!strcmp(driverName, "i915")) return fd;
return -1;


my  environment is;

- OS       CentOS Linux release 7.6.1810
- CPU   Intel(R) Core(TM) i7-6800K CPU @ 3.40GHz
- GPU    NVIDIA GeForce GTX 1080
         Following Nvidia driver is installed/
 NVRM version: NVIDIA UNIX x86_64 Kernel Module 450.80.02 Wed Sep 23 01:13:39 UTC 2020

I disabled Nouveau driver.
 # sudo mv /boot/initramfs-$(uname -r).img /boot/initramfs-$(uname -r)-nouveau.img
 # sudo dracut --force --omit-drivers nouveau /boot/initramfs-$(uname -r).img $(uname -r)
 # echo "blacklist nouveau" | sudo tee /etc/modprobe.d/modprobe.conf
 # echo "blacklist nouveau" | sudo tee /etc/modprobe.d/nouveau-blacklist.conf


# ls /dev/dri
card0 card1 renderD128 renderD129
# cat /sys/kernel/debug/dri/*/name
nvidia-drm dev=0000:03:00.0 unique=0000:03:00.0
nvidia-drm dev=0000:03:00.0 unique=0000:03:00.0
nvidia-drm dev=0000:04:00.0 unique=0000:04:00.0
nvidia-drm dev=0000:04:00.0 unique=0000:04:00.0



Could you tell me why intel Gfx driver is not found?


And I 'm planning to try another PC.   Its CPU is Intel(R) Xeon(R) W-2133 CPU @ 3.60GHz.

Does Media SDK support   Xeon W-2133 ?

Labels (1)
0 Kudos
2 Replies


Thanks for reaching out to us,

Since this is a duplicate thread of, we will no longer monitor this thread. We will continue addressing this issue in the other thread.







0 Kudos
New Contributor I

HI Jaideep、


Yes,  this issue was marked as SPAM.  So, I tried again.  

Please ignore this thread.

0 Kudos