Media (Intel® Video Processing Library, Intel Media SDK)
Access community support with transcoding, decoding, and encoding in applications using media tools like Intel® oneAPI Video Processing Library and Intel® Media SDK
The Intel Media SDK project is no longer active. For continued support and access to new features, Intel Media SDK users are encouraged to read the transition guide on upgrading from Intel® Media SDK to Intel® Video Processing Library (VPL), and to move to VPL as soon as possible.
For more information, see the VPL website.
3044 Discussions

Trouble with Intel Media SDK: getting sample_encode programm started



I'm completely new to Intel Media SDK and I just tried to run the sample_encode programm with some instructions in the command line.

This is what I typed in:
sample_encode.exe h264 -i example.yuv -o example.h264 -w 1280 -h 1024 -u quality -sw

example.yuv is a file I downloaded from the internet just to test the sample.

And these are my errors:

[ERROR], sts=MFX_ERR_NULL_PTR(-2), CSmplBitstreamWriter::Init, m_fSource pointer is NULL at src\sample_utils.cpp:406

[ERROR], sts=MFX_ERR_NULL_PTR(-2), CEncodingPipeline::InitFileWriter,  failed at src\pipeline_encode.cpp:1178

[ERROR], sts=MFX_ERR_NULL_PTR(-2), CEncodingPipeline::InitFileWriters, InitFileWriter failed at src\pipeline_encode.cpp:1239

[ERROR], sts=MFX_ERR_NULL_PTR(-2), CEncodingPipeline::Init, InitFileWriters failed at src\pipeline_encode.cpp:1419

[ERROR], sts=MFX_ERR_NULL_PTR(-2), wmain, pPipeline->Init failed at src\sample_encode.cpp:1273
Frame number: 0
Encoding fps: -0

I also tried different files and always put them in the folder of the sample_encode.exe-file.

Do you know about these errors and is there any simple error I made?
Or are there any example files you would recommend me to test?
If you need more information please tell me!

Thank you very much for your help!

Product version:
Intel Media SDK 2018 R2

Information about the platform I am building on:
OS: Windows 7 Enterprise 64 Bit
Processor: Intel Core(TM) i7-2600 CPU @ 3,40GHz
graphic driver: NVIDIA Quadro 2000, version:

0 Kudos
1 Reply

Hi Andreas,

This looks like a file I/O problem, not related to the sample. Could you double check if your application has right to the directory or simply re-target to different directory?


0 Kudos