Media (Intel® Video Processing Library, Intel Media SDK)
Access community support with transcoding, decoding, and encoding in applications using media tools like Intel® oneAPI Video Processing Library and Intel® Media SDK
The Intel Media SDK project is no longer active. For continued support and access to new features, Intel Media SDK users are encouraged to read the transition guide on upgrading from Intel® Media SDK to Intel® Video Processing Library (VPL), and to move to VPL as soon as possible.
For more information, see the VPL website.
3044 Discussions

Using sample decode library, seeing "fatal: failed to find output surface, that's a bug!"


I have a test which opens three h264 files on disk (each of different frame size & frame count) and decodes them simultaneously using three instances of the decoder. The three movies are looped infinitely and after a few hours at least one of the movies stop decoding and I notice while debugging that the problem movie is forever failing to acquire an output surface from because m_OutputSurfacesPool is empty.

Any advice is welcome.


0 Kudos
4 Replies

Hi Dave,

Can you please provide more information? What is the OS, MSS version, what application is this (our samples) etc. Please use this post to see what kind of information helps us debug the issues faster.

Can you also ensure your system has enough memory when allocating surfaces? On how to launch multiple media sessions in parallel, please refer to sample_multi_transcode for reference. Each session should have its own surfaces allocated - if the memory is running low, this could cause some issues. So, please send us more information and see if you can reproduce the issue with our samples.


0 Kudos

Thank you for the reply.

It's running on a 64-bit install of windows7 on our target hardware equipped with 4GB of memory and i5-3610ME CPU. Here is the output from the mediasdk_system_analyzer_32 (I ran the 32-bit version since the failing application is built for 32-bit):

Intel Media SDK System Analyzer (32 bit)

The following versions of Media SDK API are supported by platform/driver:

    Version    Target    Supported    Dec    Enc
    1.0    HW    Yes        X    X    [Adapter 1]
    1.0    SW    No              
    1.1    HW    Yes        X    X    [Adapter 1]
    1.1    SW    No              
    1.3    HW    Yes        X    X    [Adapter 1]
    1.3    SW    No              
    1.4    HW    Yes        X    X    [Adapter 1]
    1.4    SW    No              
    1.5    HW    Yes        X    X    [Adapter 1]
    1.5    SW    No              
    1.6    HW    Yes        X    X    [Adapter 1]
    1.6    SW    No              
    1.7    HW    Yes        X    X    [Adapter 1]
    1.7    SW    No              
    1.8    HW    Yes        X    X    [Adapter 1]
    1.8    SW    No              

Graphics Devices:
    Name                                         Version             State
    Intel(R) HD Graphics 4000                 Active
    AMD Radeon E6760                             14.501.1003.0       Active

System info:
    CPU:    Intel(R) Core(TM) i5-3610ME CPU @ 2.70GHz
    OS:    Microsoft Windows Embedded Standard 
    Arch:    64-bit

Installed Media SDK packages (be patient...processing takes some time):

Installed Media SDK DirectShow filters:

Installed Intel Media Foundation Transforms:
  Intel® Hardware M-JPEG Decoder MFT : {00C69F81-0524-48C0-A353-4DD9D54F9A6E}
  Intel® Hardware VC-1 Decoder MFT : {059A5BAE-5D7A-4C5E-8F7A-BFD57D1D6AAA}
  Intel® Hardware H.264 Decoder MFT : {45E5CE07-5AC7-4509-94E9-62DB27CF8F96}
  Intel® Hardware MPEG-2 Decoder MFT : {CD5BA7FF-9071-40E9-A462-8DC5152B1776}
  Intel® Quick Sync Video H.264 Encoder MFT : {4BE8D3C0-0515-4A37-AD55-E4BAE19AF471}
  Intel® Hardware Preprocessing MFT : {EE69B504-1CBF-4EA6-8137-BB10F806B014}

(Got tired of waiting for program to complete)


After writing the initial post I downloaded the current INDE package and installed the mediaSDK ( and tried replacing the libmfx.lib I was using with the one found in lib\win32\ and re-built and am very pleased that after nearly 24 hours the error has not occurred! With the older libmfx.lib the error occurred after two hours or so. I don't think memory was issue because I've been monitoring it closely and very little, if any, memory has been leaking and there's plenty of free memory remaining in the system at the time of failure.

I'm going to now switch to the original test which  presents the frames on the screen and let that run for days/weeks and will report back the results.


0 Kudos

Roughtly a week of running two simultaneous applications - #1 which decodes 3 movies in non-graphical form just decoding and looping as fast as possible and app #2 which decodes 6 movies graphically limited to 60fps. Something appears to be leaking in the video driver to the point where when I restarted both applications the second one is unable to decode all the movies in hardware producing a "WARNING: partial acceleration" message. From this point I tried installing the newest driver "5/25/2015, Version" and that failed, then restarting windows hung on shutdown. After a/c power reboot I installed the new driver and both tests have been running fine for two days now. Time will tell.


0 Kudos

Hi Dave, 

Thanks for keeping us updated about your experiment and results. Can you explain what you mean't by "graphical" and "non-graphical form"? Glad you downloaded the latest drive, that would have been the next recommendation. If you do come across this issue with new drivers, please let us know along with your application to debug/reproduce. Also, I wanted to check if you are running the experiments only on one system or running it on multiple test machines. 




0 Kudos