Media (Intel® Video Processing Library, Intel Media SDK)
Access community support with transcoding, decoding, and encoding in applications using media tools like Intel® oneAPI Video Processing Library and Intel® Media SDK
Announcements
The Intel Media SDK project is no longer active. For continued support and access to new features, Intel Media SDK users are encouraged to read the transition guide on upgrading from Intel® Media SDK to Intel® Video Processing Library (VPL), and to move to VPL as soon as possible.
For more information, see the VPL website.
3066 Discussions

more input data expected error on running sample code

vandanachadha
Novice
1,481 Views

Getting the following error:

./simple_2_decode -hw ~/sample_videos/sample-mkv-file.mkv
libva info: VA-API version 1.10.0
libva info: User environment variable requested driver 'iHD'
libva info: Trying to open /usr/lib/x86_64-linux-gnu/dri/iHD_drv_video.so
libva info: Found init function __vaDriverInit_1_10
libva info: va_openDriver() returns 0

More input data expected. /home/radiant/intel/MediaSDK/tutorials/simple_2_decode/src/simple_decode.cpp 11144

 

Getting this error regardless of the input file format (tried with .264 and .mp4 also)

Outputs of some ubuntu commands:

./simple_1_session -hw
libva info: VA-API version 1.10.0
libva info: User environment variable requested driver 'iHD'
libva info: Trying to open /usr/lib/x86_64-linux-gnu/dri/iHD_drv_video.so
libva info: Found init function __vaDriverInit_1_10
libva info: va_openDriver() returns 0


Implementation: HARDWARE API Version: 1.34

lspci | grep -i vga
00:02.0 VGA compatible controller: Intel Corporation Skylake GT2 [HD Graphics 520] (rev 07)

ls -l /dev/dri
total 0
drwxr-xr-x 2 root root 80 Nov 26 10:00 by-path
crw-rw---- 1 root video 226, 0 Nov 26 10:00 card0
crw-rw---- 1 root video 226, 128 Nov 26 10:00 renderD128

0 Kudos
1 Solution
vandanachadha
Novice
1,327 Views

Sorry for not replying earlier, this because my problem got solved.

 

I needed to add the linker path to the test command, and it ran successfully

LD_LIBRARY_PATH=/usr/local/lib:/opt/intel/mediasdk/lib

View solution in original post

0 Kudos
5 Replies
Gopika_Intel
Moderator
1,460 Views

Hi vandanachadha,


Thank you for posting in Media (Intel® oneAPI Video Processing Library, Intel Media SDK) forum. Could you please share us with the media_sdk version and the ubuntu version that you are using.


Regards

Gopika



0 Kudos
Gopika_Intel
Moderator
1,443 Views

Hi,

We tried the same sample with the input file format h.264 and we were able to run the sample successfully. We suggest you try the sample with another file of h.264 format. If it throws an error, please share the input file so that we can try it from our end.

Regards

Gopika 


0 Kudos
Gopika_Intel
Moderator
1,427 Views

Hi ,

Was the error resolved, Let us know your updates.

Regards

Gopika


0 Kudos
Gopika_Intel
Moderator
1,407 Views

Hi


We haven’t heard back from you. We won’t be monitoring this thread. For further issues and queries, please start a new thread.


Regards

Gopika


0 Kudos
vandanachadha
Novice
1,328 Views

Sorry for not replying earlier, this because my problem got solved.

 

I needed to add the linker path to the test command, and it ran successfully

LD_LIBRARY_PATH=/usr/local/lib:/opt/intel/mediasdk/lib

0 Kudos
Reply