Media (Intel® Video Processing Library, Intel Media SDK)
Access community support with transcoding, decoding, and encoding in applications using media tools like Intel® oneAPI Video Processing Library and Intel® Media SDK
Announcements
The Intel Media SDK project is no longer active. For continued support and access to new features, Intel Media SDK users are encouraged to read the transition guide on upgrading from Intel® Media SDK to Intel® Video Processing Library (VPL), and to move to VPL as soon as possible.
For more information, see the VPL website.

one question about HEVC decode

yiling_w_1
Beginner
438 Views
i install media sever studio profession(evaluation version)on win8.1-64 system,and the CPU is I7-4770.
 
(1)using the following command line:
sample_decode h265 -i 2_ParkJoy_1080p25.h265 -p 33a61c0b4c27454ca8d85dde757c6f8e -f 60 -wall 1 1 0 0 1 100000
it works normally.
(2)using the following command line:
sample_decode h265 -i 2_ParkJoy_1080p25.h265 -p 15dd936825ad475ea34e35f3f54217a6 -f 60 -wall 1 1 0 0 1 100000
in the begin,it run normally too.however,it would be error after a while(attached pictures for details). 
 
why item 2 fail,and how to fix it?
0 Kudos
5 Replies
Shaojuan_Z_Intel
Employee
438 Views

The first command uses HEVC hardware plugin, the second uses software plugin. I just ran the same commands as yours in a I7-4770 system, didn't see your problem. Does your system have the latest driver? When did the second command stop? Did it finish full video? Thanks.

0 Kudos
yiling_w_1
Beginner
438 Views
(1)i try it on an other machine,but the same symptom.
(2)Does your system have the latest driver?
update the driver to the last version,but no change.-->in the process of install media sever studio,it update driver automatically,so i think it not likely caused by driver.
(3)When did the second command stop? Did it finish full video? 
my test video only 250 frames,and it stoped in 997 frame,so i think it finish full video,and stopped at the third cycle(attached pictures for details).
(4)my media sever studio is evaluation version,wether it's possible caused by it.
0 Kudos
Shaojuan_Z_Intel
Employee
438 Views

 I ran the same command with the SW plugin for many loops of video, couldn't reproduce the problem. Were you using the latest Samples? Can you provide the output from the system analyzer at MediaServerStudioInstallationDirectory/Software Development kit/tools/mediasdk_sys_analyzer? Can you upload your input file too? Thanks!

0 Kudos
yiling_w_1
Beginner
438 Views
 
(1)Were you using the latest Samples?
Yes,version:6.0.0.49
(2)Can you provide the output from the system analyzer at MediaServerStudioInstallationDirectory/Software Development kit/tools/mediasdk_sys_analyzer?
one error.pls see the attached picture for details,picture name:error.png
(3)Can you upload your input file too?
as the attachment,file name:2_ParkJoy_1080p25.rar
(4)more information including SDK version;samples version;system information;CPU information is in attached picture too,which is named system.png 
0 Kudos
Shaojuan_Z_Intel
Employee
438 Views

I just reproduced your error with an evaluation version installed. For evaluation edition, there is limitation for maximum number of frames supported. In this case, it is 1000 frames. Sorry for taking so long to find out and didn't confirm it earlier. Thanks!

0 Kudos
Reply