Media (Intel® Video Processing Library, Intel Media SDK)
Access community support with transcoding, decoding, and encoding in applications using media tools like Intel® oneAPI Video Processing Library and Intel® Media SDK
Announcements
The Intel Media SDK project is no longer active. For continued support and access to new features, Intel Media SDK users are encouraged to read the transition guide on upgrading from Intel® Media SDK to Intel® Video Processing Library (VPL), and to move to VPL as soon as possible.
For more information, see the VPL website.
3066 Discussions

using sample_multi_transcode_drm transcoding 1080p.h254(900 frame), sometime, the sample_multi_transcode_drm dont end

shiyin_x_
Beginner
667 Views

 

sir:

         using sample_multi_transcode_drm transcoding 1080p.h254(900 frame), sometime, the sample_multi_transcode_drm dont end its process which still use memory and cpu(very little),  and the transcoding file only part is completed.    i use the command "top", get the fact what the sample_multi_transcode_drm would always be  here, the content of transcoding result file dont change. 

        if i want to end the process of the sample, i must using "kill PID" command.

0 Kudos
3 Replies
Surbhi_M_Intel
Employee
667 Views

Hi Shiyin, 

To debug this better can you give us more details about the issue you have reported above like system details-processor and graphics info, the cmd line you are using? I have tried this multiple times scenario at our end and didn't the issue. Process is killed on it's own after the file write completes.The cmd line I have used for my testing - 
./sample_multi_transcode_drm -i::h264 ducks.h264 -o::h264 out.h264 -w 1920 -h 1080 -b 10000 -f 30 -hw

Can you confirm if you have modified the sample and are you seeing this issue with a particular input? Is this issue only seen with sample_multi_transcode or with other samples as well?
Please let us know your findings. 

Thanks,
Surbhi


 

0 Kudos
shiyin_x_
Beginner
667 Views

SURBHI M. (Intel) wrote:

Hi Shiyin, 

To debug this better can you give us more details about the issue you have reported above like system details-processor and graphics info, the cmd line you are using? I have tried this multiple times scenario at our end and didn't the issue. Process is killed on it's own after the file write completes.The cmd line I have used for my testing - 
./sample_multi_transcode_drm -i::h264 ducks.h264 -o::h264 out.h264 -w 1920 -h 1080 -b 10000 -f 30 -hw

Can you confirm if you have modified the sample and are you seeing this issue with a particular input? Is this issue only seen with sample_multi_transcode or with other samples as well?
Please let us know your findings. 

Thanks,
Surbhi

 

sir:

          i use ./sample_multi_transcode_drm -i::h265 ducks.h265 -o::h265 out.h265 -w 1920 -h 1080 -n 900 -b 1000 -f 30 -hw -pe  e5400a06c74d41f5b12d430bbaa23d0b, but the problem come. i need some time to test the problem.  

          

 

0 Kudos
Surbhi_M_Intel
Employee
667 Views

Hi, 

It wasn't clear from your earlier post whether you are doing h264 or h265 transcode. I am wondering what are your system specifications and which Media Server Studio and sample version are you using? Please confirm o/p of below tests- 

1. If behavior is only seen for HEVC to HEVC transcode?
2. Any specific inputs causing this? Please send us the input to reproduce this issue at our end. 
3. Do you see same issue when doing HEVC encode or decode only?

Thanks,
Surbhi

0 Kudos
Reply