Nios® II Embedded Design Suite (EDS)
Support for Embedded Development Tools, Processors (SoCs and Nios® II processor), Embedded Development Suites (EDSs), Boot and Configuration, Operating Systems, C and C++
12469 Discussions

Nios® II EDS WSL and Ubuntu versions

ETang2
Beginner
381 Views

Hello, in the Intel® FPGA Software Installation and Licensing we need to install WSL 1 and Ubuntu 18.04 : https://www.intel.com/content/www/us/en/docs/programmable/683472/21-4/installing-windows-subsystem-f...

 

WSL 1 is old and Ubuntu 18.04 will no longer be supported in April 2023!

 

Do you know if this will be upgraded to support WSL 2 and at least Ubuntu 20.04 (22.04 ?)

 

Thanks

Eric

0 Kudos
1 Solution
EBERLAZARE_I_Intel
314 Views

Hi,


We currently have no support for Windows 11 yet, as it is still recommended to use Linux environment..


Regarding the support, you may refer to:

https://www.intel.com/programmable/technical-pdfs/726952.pdf#page=7




View solution in original post

6 Replies
EBERLAZARE_I_Intel
354 Views

Hi,


As of today, we have no update regarding the future support to switch to WSL 2 nor Ubuntu 20.04.


We do recommend users to use Linux environment for better future experience.


ETang2
Beginner
348 Views

Hi, thank you for the answer.

Another solution could be to use NIOS V instead of NIOS II. Could NIOS V be implemented on DE10-Lite card ?

LFrin
Novice
333 Views

Hi, did you try wsl version 1 with Ubuntu 20.04 lts? The Nios II EDS runs fine at my machine with this Ubuntu version.  I think the new Nios V is only supported by the Quartus Prime Pro version.

ETang2
Beginner
325 Views

Hi, no i did not try. I will test but i use win11 + wsl version 2 ...

About NIOS V, you are right it is only supported by the pro version which is not available for MAX10.

EBERLAZARE_I_Intel
342 Views

Hi,


I am checking the info with our internal team, I shall let you know once we have them.


EBERLAZARE_I_Intel
315 Views

Hi,


We currently have no support for Windows 11 yet, as it is still recommended to use Linux environment..


Regarding the support, you may refer to:

https://www.intel.com/programmable/technical-pdfs/726952.pdf#page=7




Reply