Nios® II Embedded Design Suite (EDS)
Support for Embedded Development Tools, Processors (SoCs and Nios® II processor), Embedded Development Suites (EDSs), Boot and Configuration, Operating Systems, C and C++
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
12452 Discussions

Possible Bugs in Eclipse Project BSP

SeanAB
New Contributor I
256 Views

Quartus Prime Lite Ver 21.1.0 Build 842 10/21/21 - Windows 10 Host system

Eclipse Mars.2 rel 4.5.2

 

When the Eclipse BSP project files are created, I keep see inga couple errors pop-up in the BSP source files.

 

#1 alt_read.c

 

Line 120 appears to have an error:


ALT_ERRNO = EBADFD;

should be

ALT_ERRNO = 0xEBADFD;

 

#2 alt_sys_inti.c - when a Timer is added to the design

Line 74 - shows alt_no_storage is undeclared refers to the following in

 

alt_avalon_timer.h calls this out:


#define ALTERA_AVALON_TIMER_INSTANCE(name, dev) extern int alt_no_storage

Am I supposed to set this value to something?

 

 

 

0 Kudos
5 Replies
hareesh
Employee
205 Views

Hi SeanAB,


can you please share your plat form design screen shot and .sopcinfo file.


thanks,


SeanAB
New Contributor I
195 Views

Attached are the request file. Not sure if these are bugs or not. The application runs just fine, but the BSP showing bugs is a little puzzling.

hareesh
Employee
167 Views

Hi @SeanAB,

 

With your shared .socpinfo file, I recreated the eclipse project. I haven't seen any problems when I build a complete project. you can  see console window output in bellow attachment. Once, update your Quartus software and try it.

SeanAB
New Contributor I
161 Views

The issues is in Eclipse. In the HAL source alt_read.c file, the attached bug appears. Again not sure if this is really an bug as the application builds and runs without issue.

hareesh
Employee
147 Views

Hi @SeanAB ,

just disable the Symbol is not resolved option in code analysis section. go through the reference link and attachment.

 

link:

https://www.intel.com/content/www/us/en/support/programmable/articles/000084712.html 

Reply