Nios® V/II Embedded Design Suite (EDS)
Support for Embedded Development Tools, Processors (SoCs and Nios® V/II processor), Embedded Development Suites (EDSs), Boot and Configuration, Operating Systems, C and C++

Downloading ELF Process Fail

Yevpator
Novice
537 Views
I have been facing the following problem since I started working with NIOS-II (Arria-ii and Max10). From time to time, suddenly, it's impossible to connect to the target with Eclipse (version 18.1). Eclipse throws the following error: Downloading ELF Process failed.
I cannot connect with Eclipse, while I can connect with Altera Quartus Programmer, which probably means this is not a problem with signal integrity or in FPGA, but something with Intel SBT. In order to resolve the problem, I switch power off/on, play with USB, delete and define debugging setting in Eclipse and some other similar things, until Eclipse recovers. Sometimes it takes 1-2 hours until the problem recovers and then sometimes 15 min after I encounter the problem again. We are starting a new project and debugging capabilities are very important to me and I want to resolve the problem.
I see there is a much newer Quartus SW SBT version (20+), but I don't know if it resolves my issue and whether it is the problem at all.
When I use Eclipse to debug and Quartus Programmer to load sof file, is it the same path for my FPGA?
My FPGA is Arria-ii.
I am trying to debug NIOS-II.

Will be glad to hear any idea one can suggest me to try.
0 Kudos
9 Replies
aikeu
Employee
441 Views

Hi Yevpator,


Is it a sometimes download fail problem regarding your issue?

Can you check if this is related to your code size changes especially every time a download is being performed?


Thanks.

Regards,

Aik Eu


0 Kudos
Yevpator
Novice
415 Views
Dear Aik Eu,
No it is not related with the code size. Sometimes i succeed to enter the debug mode, suddenly the debug session fails or i exit and next time I try to load the same elf file without changing its size it does not work.
0 Kudos
aikeu
Employee
392 Views
0 Kudos
Yevpator
Novice
376 Views
Thank you for your comment.
The clock is ok - as I wrote before I manage to program or load image file with the Programmer or even with NIOS shell (tried that today). If I had issue with the clock, I wouldn't be able to load sof file with the Altera programmer, but it works good, the problem happens only while I am debugging with Eclipse.
0 Kudos
aikeu
Employee
272 Views

Hi Yevpator,


I am still checking with the team if there is any similar downloading elf file issue.


Thanks.

Regards,

Aik Eu


Yevpator
Novice
248 Views

Interesting that several times when I had the problem with Eclipse to load elf, i opened command shell and was able to load elf into my fpga. That is to say the problem related with the IDE (Altera SW SBT).  I recall that in the past i experimented with opening another project when i had problems to load elf with a current one and it also worked for me. I use version 18.1, i would consider upgrading the  Altera SW SBT if i knew the issue was addressed and resolved , but i failed to find this issue in the release notes , therefore i don't want to waste time on moving to a new version that won't release my problem.

 

Thanks 

0 Kudos
aikeu
Employee
206 Views

Hi Yevpator,


Glad that you have resolve the issue on your side.

Anyway after checking with the team, there is no much intermittent failure in the downloading elf process.

Mostly is failure due to hardware IP/BSP setting as below:



Thanks.

Regards,

Aik Eu


0 Kudos
aikeu
Employee
168 Views

Hi Yevpator,


We do not receive any response from you to the previous question/reply/answer that I have provided. This thread will be transitioned to community support. If you have a new question, feel free to open a new thread to get the support from Intel experts. Otherwise, the community users will continue to help you on this thread. Thank you.


Thanks.

Regards,

Aik Eu


Yevpator
Novice
150 Views
Actually, I didn't respond because I don't get messages to my email when a new response is posted .
I didn't resolve the issue. It's a nightmare. Thank you
0 Kudos
Reply