Nios® V/II Embedded Design Suite (EDS)
Support for Embedded Development Tools, Processors (SoCs and Nios® V/II processor), Embedded Development Suites (EDSs), Boot and Configuration, Operating Systems, C and C++
12626 Discussions

Eclipse crashing whilst connected to target

Oliver_I_Sedlacek
New Contributor III
602 Views

As per title, after running for a few minutes my Eclipse hangs quite consistently. When I close  I get this exception report:

 

Anyone seen this, got any work arounds?

0 Kudos
11 Replies
BoonBengT_Intel
Moderator
530 Views

Hi @Oliver_I_Sedlacek,


Thank you for posting in Intel community forum and hope all is well.

Quick clarification, the Eclipse mention here is where you are dealing with Nios processor as well as FPGA related hardware?

And just some confirmation on the below details:

- Which eclipse version are you using?

- Is it windows or linux which you are working with?

- Based on the error quartus would be 20.1 lite?


Hope to hear from you soon

Best Wishes

BB


0 Kudos
Oliver_I_Sedlacek
New Contributor III
521 Views

Eclipse version is Mars.2 Release (4.5.2)

NIOS II EDS is version 20.1.0.v20201112-1755

Host OS is Windows 10 Pro 64 bit

I'm developing both hardware and code and for the year or so  I've been doing my development I've not seen this before.

0 Kudos
Oliver_I_Sedlacek
New Contributor III
426 Views

All gone very quiet, do I start a support case?

0 Kudos
JingyangTeh
Employee
401 Views

Hi Oliver


This is the first time I am looking at this error message.

Could you try sharing your project so that I could try to reproduce the error message that you could see?


Regards

Jingyang, Teh


0 Kudos
Oliver_I_Sedlacek
New Contributor III
391 Views

Attached. Not sure how you can recreate this without hardware though.

0 Kudos
JingyangTeh
Employee
267 Views

Hi Oliver


Just to ask, when you are debugging with the Eclipse.

Are you running the juart-terminal together?

If yes, could you try closing the juart-terminal before start debugging.

After flashing the board and attached the debugger only you open the juart-terminal.


Regards

Jingyang, Teh


0 Kudos
JingyangTeh
Employee
218 Views

Hi Oliver


Are you still experiencing Eclipse crashing after closing the the juart-terminal before connecting eclipse?


Regards

Jingyahng, Teh


0 Kudos
JingyangTeh
Employee
143 Views

Hi Oliver


Are you still observing crash when connecting to eclipse?


Regards

Jingyang, Teh


0 Kudos
Oliver_I_Sedlacek
New Contributor III
128 Views

I'm now very strict about the order in which I connect the debug adapters and launch Eclipse so I have a work around.

The fragility of Eclipse is still disappointing though.

0 Kudos
Oliver_I_Sedlacek
New Contributor III
114 Views

How quickly things changed, just crashed Eclipse again.

0 Kudos
JingyangTeh
Employee
63 Views

Hi


Usually I will "Terminate and Remove Connection" in eclipse and close any juart-terminal after each debug session or before flashing.



Regards

Jingyang, Teh


0 Kudos
Reply