Nios® V/II Embedded Design Suite (EDS)
Support for Embedded Development Tools, Processors (SoCs and Nios® V/II processor), Embedded Development Suites (EDSs), Boot and Configuration, Operating Systems, C and C++
Announcements
All support for Intel NUC 7 - 13 systems has transitioned to ASUS. Read latest update.
12583 Discussions

Having a problem when creating a new Nios ii Application and BSP from template

TBroc6
Beginner
4,304 Views

I am following the simple hello world tutorial for my DE0-nano. I am able to select the proper SOPC information file, and cpu. However when clicking finish I get the error:

 

Failed to execute: wsl dos2unix create-this-bsp;

./create-this-bsp --cpu-name --no-make

 

I was wondering if anyone had some insight to the source of the error? thanks

0 Kudos
9 Replies
MEIYAN_L_Intel
Employee
4,193 Views

Hi,

May I know the version for Nios II Eclipse software used?

May I know do you follow the user guide as document below:

https://www.intel.com/content/dam/www/programmable/us/en/pdfs/literature/tt/tt_my_first_nios_sw.pdf

Thanks

0 Kudos
SHard2
Novice
4,084 Views

Hi

I am having exactly the same problem, has there been any resolution to this?

Many thanks

Simon

0 Kudos
SThor8
New Contributor I
4,053 Views

 

There is a, since 2 month, a well known problem with detailed description of the issue with later windows updates and wsl in combination with quartus, see

https://community.intel.com/t5/Nios-II-Embedded-Design-Suite/Error-s0-Error-during-execution-of-quot-C-intelfpga-20-1-quartus/m-p/1207193#M50127

It have been assured that people are working this since early July.

Unless programmers at Intel have 2 months forced vacation it must be a extremely difficult problem that uses almost all resources, working 24h on this.

SHard2
Novice
4,046 Views

Hi

I have had to support shipping equipment and have not had the time to be able to wait for a solution or experiment to find a work around. I have needed to roll back to 18.1 Build 625 to find a version where it is possible to use the NIOS II tool chain fully.

Every release from Q18.1 update 1 to date appears to have a problem with the NIOS II tool chain.

I am struggling to understand why this appears to be a recurring problem.

Regards

Simon

0 Kudos
DanielB
Beginner
3,741 Views

Hello, I am attempting the same tutorial and getting exactly the same error. 

I have seen various suggestions to fix it on the web, but noe of them worked for me.

Is there a proper fix for this problem?

I am using Quartus II 20.1 Lite, and the recommended version of Eclipse.

 

Thanks,

 

Daniel.

0 Kudos
DanielB
Beginner
3,727 Views

Hi all,

Well, I don't know exactly what happened, but my Windows decided to do a massive update yesterday evening. After this and the ensuing restarts, it suddenly started working, and successfully created the Hello World project.

If it's important, I started the Eclipse from the Nios II command shell, following suggestions on the web. However, this yesterday also did not work.

 

Thanks,

 

Daniel

0 Kudos
meenalkb
Novice
3,595 Views

Hi Daniel,

Would you be able to tell us what version of Windows you are now on? I am also seeing this issue and would like to replicate your "fix"...

 

Many thanks

0 Kudos
Shainy
Beginner
2,376 Views

Hi,

I face the same issue with Eclipse, and really appreciate if someone could let me know a fix to this. Thanks in advance!

 

Regards,

Shainy 

0 Kudos
praveenkumar
Beginner
2,361 Views

hi shainy  ,

please try with

hello world  small

0 Kudos
Reply