Nios® V/II Embedded Design Suite (EDS)
Support for Embedded Development Tools, Processors (SoCs and Nios® V/II processor), Embedded Development Suites (EDSs), Boot and Configuration, Operating Systems, C and C++
The Intel sign-in experience has changed to support enhanced security controls. If you sign in, click here for more information.

NIOS II v11.0 BSP Project

Honored Contributor II

Hi. I would like to ask for help. I've tried to find the BSP project in the NIOS II v11.0 but there are none for this type of project. 


Because of that, all my header files can't be recognise at all. 


I even went to help file but it didn't really help.  


Does anyone know how to create a BSP project to insert .sopcinfo for NIOS II Eclipse v11.0?
0 Kudos
4 Replies
Honored Contributor II

You question is a little off putting but i find I perform the following steps. With one wierd thing that pees me off (i think its a bug, but its in both 10 and 11, so maybe i'm the bug. see bold point below) 


1. File/New/"Create Nios Application and BSP from Template". 

2. Select the sopcinfo your doing this for. 

3. Set your directiories for project storage name etc. 

4. Select the type of project. e.g "blank". Click next. 

5. because i use ucos i have to create the bsp manually. so i click create and a bsp is generated. 

6. this newly generated bsp appears in the main window explorer (you can see it in background behind the new creation popups). but it does not allow me to select it as the bsp to use for this new project. 

7. I then have to cancel this new project window and then select File/New/"Create Nios Application". 

8. I then point this new application to the BSP i created before. 


So i know this works, but its wierd. I suppose i could just create them both singularly with doing the 'start the both creation, make the bsp, then cancel' steps. 

But shouldn't the create two at a time work?! 


You can follow my method until someone smarter en-lightens us both.
Honored Contributor II

I'm really sorry bout my language to put you off.  


What I mean by the help file is different because the eclipse software for 11.0 is kind of different from other previous version as this version needed toolchains tools and don't have a selection for "Create Nios Application and BSP from Template" and it just have C++ project.  


I guess I'm still new with Eclipse and need to brush up my skills. Thanks for your help. :)
Honored Contributor II

The problem is solved.. Thanks alot.. Looks like I need to re-install the NIOS II program once again and this time the new file got NIOS II application and BSP from Template. Such a funny problem.

Honored Contributor II

To AsValdr: 

I too was facing the same problem. Worse the applicaiton will not build and it was a nightmare truing to get a new project up. 


I stumbled upon the script file and it a breeze to use it. Just setup a few tiems and run it from the command prompt. It creates the application and 

BSP and it can be opened form the IDE and compiled. 


Only the settings.bsp file need to be saved from the BSP folder.