Nios® V/II Embedded Design Suite (EDS)
Support for Embedded Development Tools, Processors (SoCs and Nios® V/II processor), Embedded Development Suites (EDSs), Boot and Configuration, Operating Systems, C and C++

NIOSII download problem

Altera_Forum
Honored Contributor II
1,161 Views

HI 

 

when I download my project , 

it generate an error , 

but I have no idea what is the error ? 

How do I solve it? 

https://www.alteraforum.com/forum/attachment.php?attachmentid=7649
0 Kudos
4 Replies
Altera_Forum
Honored Contributor II
295 Views

Hi, The error is not "Pausing target processor : not responding" because immediately after it tried again and it is OK 

The error is "Assert "m_state == STATE_DEBUG" failed" in nios2oci.cpp file
0 Kudos
Altera_Forum
Honored Contributor II
295 Views

 

--- Quote Start ---  

Hi, The error is not "Pausing target processor : not responding" because immediately after it tried again and it is OK 

The error is "Assert "m_state == STATE_DEBUG" failed" in nios2oci.cpp file 

--- Quote End ---  

 

 

Thank you for your reply , I understand the true error , but what can I do for this error? 

 

my project build and BSP build are all OK 

 

I don't understand what is causing this error?  

 

Is Hardware? Is Timing? Is Qsys's IP? Is formula? 

 

Anyone give me some advice?  

 

Thanks. 

 

------------------------------------------------------------------------------------------------------- 

 

--- Quote Start ---  

Are you using a custom board, Altera dev kit or university board ? 

 

 

Which NIOS II tools ? Is suppose Nios II SBT from Quartus & Nios version >=10 (because I see Qsys). 

.... 

 

 

Hey, see http://www.altera.com/support/kdb/solutions/rd04012011_290.html ;-) 

--- Quote End ---  

 

 

 

1. I use Bemicro SDK =>http://www.arrownac.com/solutions/bemicro-sdk/ 

 

 

2.Quartus II 11.0 & Nios II 11.0 Software Build Tools for Eclipse 

 

 

3.when I see the compiltion report , I find my altera_reserved_tck negative number. 

https://www.alteraforum.com/forum/attachment.php?attachmentid=7666  

 

 

It will be affected? If yes, how to improve it? 

 

 

P.S I have joined the .sdc files 

https://www.alteraforum.com/forum/attachment.php?attachmentid=7667
0 Kudos
Altera_Forum
Honored Contributor II
295 Views

Are you using a custom board, Altera dev kit or university board ? 

 

Which NIOS II tools ? Is suppose Nios II SBT from Quartus & Nios version >=10 (because I see Qsys). 

.... 

 

Hey, see http://www.altera.com/support/kdb/solutions/rd04012011_290.html ;-)
0 Kudos
Altera_Forum
Honored Contributor II
295 Views

 

--- Quote Start ---  

Are you using a custom board, Altera dev kit or university board ? 

 

Which NIOS II tools ? Is suppose Nios II SBT from Quartus & Nios version >=10 (because I see Qsys). 

.... 

 

Hey, see http://www.altera.com/support/kdb/solutions/rd04012011_290.html ;-) 

--- Quote End ---  

 

 

1.I use the Bemicro SDK =>http://www.arrownac.com/solutions/bemicro-sdk/ 

 

2.Quartus II 11.0 & Nios II 11.0 Software Build Tools for Eclipse 

 

3.When I see the compilation report ,I find my altera_reserved_tck is negative number 

 

https://www.alteraforum.com/forum/attachment.php?attachmentid=7662  

 

It will be affected? If yes, how to improve it? 

 

P.S I have added .sdc file  

https://www.alteraforum.com/forum/attachment.php?attachmentid=7663
0 Kudos
Reply