Nios® V/II Embedded Design Suite (EDS)
Support for Embedded Development Tools, Processors (SoCs and Nios® V/II processor), Embedded Development Suites (EDSs), Boot and Configuration, Operating Systems, C and C++
The Intel sign-in experience has changed to support enhanced security controls. If you sign in, click here for more information.
12518 Discussions

Nios II Hardware Configuration option missing from Eclipse Run menu

Honored Contributor II


I have been having issues with the Eclipse environment so I went back to basics and build the Hello World small program. When I got to tried to run the program there was no Nios II hardware configuration available on the run configuration menu. I tried to create a new run configuration but the error i got was: "Plug-in com.altera.sbtgui.launch was unable to load class com.altera.sbtgui.launch.hardware.ui.Nios2HardwareLaunchConfigurationTabGroup." 

I am running Altera 11.1 withe the laterst eclipse tools and sp2 under WIndows 7 Enterprise. I have been seeing other strange behaviors. Any suggestions? 

Thanks! John
0 Kudos
2 Replies
Honored Contributor II



I had an similar problem after the update from quartus 10 to quartus 11.1sp2. After some mails with altera support, I got a solution. 


First start a dosbox an go to "quartus installation directory"\11.1sp2\quartus\bin. 

Here start the file "jtagconfig.exe". These shows you the installed programming devices. In my case, there were more than one USB-Blaster in this list. That was the problem. 

I could not really remember how I removes the unnecessary Blaster. There was a command like "-remove -1", where the 1 was the number of the device in the list! 

I hope you will find the command. Maybe you could post it, if you are successful. 


Greets Sim
Honored Contributor II

Step 1 : Run application in compatibility mode for Windows XP 

Step 2 : Run the application as administrator.