Nios® V/II Embedded Design Suite (EDS)
Support for Embedded Development Tools, Processors (SoCs and Nios® V/II processor), Embedded Development Suites (EDSs), Boot and Configuration, Operating Systems, C and C++
The Intel sign-in experience has changed to support enhanced security controls. If you sign in, click here for more information.

configure kernel fails

Honored Contributor II

when i want to configure my kernel in the drop down menu, the window opens shortly and closes a second later. normally opens the blue configuration window, but here only the bash window for just a moment. i tried it with different kernels, it's always the same. 


knows someone this problem???? 


0 Kudos
4 Replies
Honored Contributor II

That's a known problem... could've sworn there was a thread about this earlier that I could point you to. Anyhoo... 


The only tested and true method of debugging this issue is: 


(1) modify the configure.bat file in your kernel project within the Nios II IDE 

(2) remove the @start from the beginning of the line in the batch file 

(3) open up a regular command prompt (not a Nios II SDK Shell) 

(3a) run cd ...altera\kits\nios2\bin\eclipse\workspace\<kernel project> 

(3b) run configure.bat 


You should now be able to view the error messages. 


Common issues: 


gcc or nios2-elf-gcc not found... 


... you may need to run SOPC Builder at least once in order for your Quartus II/SOPC Builder installation to be complete. After running SOPC Builder, try configuring the kernel again 


crt0.o not found... 


... this is trickier, you need to double check that a crt0.o file exists within the ...quartus/bin/cygwin/usr/lib directory. This is the one that the kernel configuration is trying to link against. If it&#39;s there then something is different about your mount points than what we expect it to be. We typically unmount the current /usr/lib if it&#39;s mounted, so you may try that from the Nios II SDK Shell before attempting to configure your kernel again. 


any other error messages, let me know...
Honored Contributor II

I&#39;ve had a similar problem on a system on which a standalone copy of Cygwin was installed. I&#39;m guessing that the uClinux installer found Cygwin and not Quartus&#39; Cygwin, which led to some kind of problem finding gcc. I couldn&#39;t get Cygwin and Quartus Cygwin to coexist, so I uninstalled Cygwin, reinstalled uClinux, and it all worked. 


If the installer asks you for the location of Cygwin, make sure you point it to Quartus II 4.0&#39;s Cygwin.
Honored Contributor II

hi, can somebody tell me the correct command for umount the stuff. 


Honored Contributor II

no sorry i&#39;ve got another problem 


make: Entering directory `/cygdrive/c/altera/kits/nios2/bin/eclipse/plugins/com. 


HOSTCC scripts/basic/fixdep 

gcc: not found 

make[2]: *** [scripts/basic/fixdep] Error 127 

make[1]: *** [scripts_basic] Error 2 

make: *** [menuconfig] Error 2 

make: Leaving directory `/cygdrive/c/altera/kits/nios2/bin/eclipse/plugins/com.m 



does anyone know something about this error!! 

the gcc does exist!!