Nios® V/II Embedded Design Suite (EDS)
Support for Embedded Development Tools, Processors (SoCs and Nios® V/II processor), Embedded Development Suites (EDSs), Boot and Configuration, Operating Systems, C and C++
All support for Intel NUC 7 - 13 systems has transitioned to ASUS. Read latest update.

dm9000 device tree

Honored Contributor II



Can someone give me some instructions, howto get dm9000a Ethernet card to work with latest nios2 linux community edition (kernel 3.3.0-rc7) with device tree? My development board is DE2-70 

I tried to generate the device tree structure with sopc2dts utility and I got this message "Component DM9000A of class DM9000A_IF is unknown" 

so I edited the dm9000 section in dts file to 


DM9000A: ethernet@0x940a180 { 

compatible = "davicom,dm9000"; 

reg = < 0x0940A180 0x00000008 >; 

interrupt-parent = < &cpu >; 

interrupts = < 5 >; 

}; //end unknown@0x940a180 (DM9000A) 



And added DM9000A support into kernel, 

the driver is loaded, but it doesnt recognize the dm9000 card  


io scheduler cfq registered (default) 

ttyJ0 at MMIO 0x4001020 (irq = 1) is a Altera JTAG UART 

console [ttyJ0] enabled, bootconsole disabled 

console [ttyJ0] enabled, bootconsole disabled 

dm9000 Ethernet Driver, V1.31 

mousedev: PS/2 mouse device common for all mice 

TCP cubic registered 


I tried it before with older version, configured with ptf file and it worked good, but with the newer version I cannot get it up.  

Any help would be appreciated 

Thank You
0 Kudos
1 Reply
Honored Contributor II

What is the version you are developing with? 


See that: 


In the Nios II v9.0 or later, the TCP/IP includes the networking stack of the Nichstack, however, the DE2_NET project was built on the LWIP. The driver for the DM9000A should be different in the Nichstack to the LWIP. Then, if you want to migrate the DE2_Net project to Nios II v11.1, you have to create a new driver for the DM9000A at first.
0 Kudos