Nios® V/II Embedded Design Suite (EDS)
Support for Embedded Development Tools, Processors (SoCs and Nios® V/II processor), Embedded Development Suites (EDSs), Boot and Configuration, Operating Systems, C and C++
The Intel sign-in experience has changed to support enhanced security controls. If you sign in, click here for more information.

.elf file in NIOS II SBT tool

Honored Contributor II

Hi, in our college we planned to purchase Quartus II software . So we were doing a project in designing a Nios II soft core processor with Quartus II 14.1 version. 

After creating Qsys we have done complete compilation in Quartus II with no errors.But we stucked at using SBT tool since it showing error as project does not have an ELF file.
0 Kudos
1 Reply
Honored Contributor II

Same problem here. The build process simply doesn't generate an elf file, it simply does not and it doesn't produce any error. One notices that there is no elf file once one tries to use it. 


Same happens in Altera monitor program (from the University Program): during build it says ELF generater at *PATH* and finishes the compile as usual but, in fact the elf is not generated .... is nowhere to be found (I even searched the whole disk drive for it) 


weird weird weird 


This is on windows 7 pro 64bit. I finally have instaled multiple versions of Quartus II side by side but this problem is on all of them. I tried the same thing (with Altera Monitor program) on a windows 8.1 computer and there the build worked correctly. But currently SoC EDS is not supported on windows 8.