Processors
Intel® Processors, Tools, and Utilities
14795 Discussions

Frequent Game Crashes

weid69
Beginner
464 Views

Processor: Intel Core i9-12900K

Motherboard: GIGABYTE Z690 AORUS PRO

GPU: RTX 3060

Memory: Kingston Fury Beast 32GB (DDR5)

Operating System: Windows 10

 

 

I have recently built a new computer in December of 2023. I got about 3 months of trouble free use from the computer before I started experiencing issues. Now whenever I play any game, it will crash anywhere from 2 hours of play all the way down to less than 5 minutes of play. Other applications besides games run fine with no issue (Google Chrome, Spotify, Steam, ect. ) Recently it has been getting worse.

 

So far I have:

- Ran a "sfc /scannow" scan and repaired my windows

- Re-installed Windows

- Tried a different but known working graphics card

- Tried a different but known working memory stick

- Disabled XMP

- Increased voltage to the memory

- Tried running the game on the SSD that my operating system is on

- Turned "Hardware Acceleration" off for Discord

 

None of these have made the issue any better or worse. I am getting frustrated as I am running out of things to check. Any guidance or suggestions would be greatly appreciated.

0 Kudos
3 Replies
kstom00
Beginner
338 Views
Hey Weid69, I totally get how frustrating this can be. I ran into a similar issue with my rig a while back, and after trying a bunch of different solutions, I found a surprisingly easy fix that worked perfectly.

It turns out that the issue was related to an obscure setting in the Windows Registry that can affect high-performance applications like games.

Here’s how I did it (took about ~5 mintutes)

1. Press **Win + R** to open the Run dialog.
2. Type **regedit** and press Enter to open the Registry Editor.
3. Navigate to the following path: `HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters`
4. Look for a DWORD value named **DisableTaskOffload**. If it’s not there, create a new DWORD (32-bit) value with that exact name.
5. Set the value of **DisableTaskOffload** to `1`.
6. Close the Registry Editor and restart your computer.

This setting disables task offloading to your network adapter, which can sometimes interfere with gaming performance and stability. After making this change, my games stopped crashing entirely.

Give this a try, since your experiencing almost identical issues to me, I’m confident it will fix the issue. Let me know if you need any further assistance.
- Kevin

0 Kudos
weid69
Beginner
283 Views

Thanks for the advice Kevin! I dropped it off at Microcenter for their diagnostic tests.

But I will give this a shot when I get my PC back.

0 Kudos
kstom00
Beginner
161 Views

Hope everything went well!

0 Kudos
Reply