Processors
Intel® Processors, Tools, and Utilities
14796 Discussions

I9-14900K BSOD and constant program closing/crashes

Weatherby
Beginner
402 Views

Hey all,

I built this box on launch day of the 14900k. It consists of the following:

Asus Z790-H motherboard
i9-14900K CPU
Corsair Dominator Titanium 6600 DDR 5 2x 32GB

A samsung 980 nVME for boot

an RTX 3090 TI FE gpu (under-volted using MSI Afterburner)

a 1200w PS

CPU cooling is provided by a 360 AIO (DeepCool) plus a slew of Noctua 3000 ipc and 2000 ipc 120 and 140mm fans. The AIO has some 120mm Lian-Li fans and the original DeepCool 120mm fans.

CPU temps are 50-70 c or so, spiking maybe to 90c under loads.

The problem is this:

I get BSODs, and programs closing on their own with no errors being displayed in win 11. The programs that close include: icue, Discord and MSI Afterburner, but I have had other programs either not function or close on their own as well. (For instance, while testing vram and the gpu Cinebench occasionally just closes.)

Discord is the worst for it, it just either restarts randomly or closes all together. icue and Afterburner close at random on their own as well.

Also, python, while running stable diffusion will randomly either throw an error, and then when you re-launch work just fine even at that same spot in the startup process, or it'll just end itself, and when you look at the console it just says 'hit any key to continue' no error or anything.

When I first purchased the parts, I was down about a month due to bad DIMMs. Corsair replaced them and everything tests ok. I tried XMP2 profile, and get memory errors, switched to XMP1 for DDR 5 6600 and it passes the memtests for hours without issue.

I think I've eliminated any ddr issues, gpu, well, it seems to be working fine, but I'm not 200% sure on that... It passes cinebench just fine, but idk if it's testing the vram or the whole card or to what extent.

It should be noted that even set to default settings, this all occurs, so I'm not sure it's related to undervolting the 3090TI.

I also have issues with other programs that are random, like Krita will sometimes not open an image unless I try and open it a specific way. Dragging and dropping an image into the program works, sometimes, but sometimes it does not. When it does not, I then have to try right clicking and open with. Sometimes that opens it, sometimes it doesn't. Then I have to move on to ctrl+o in the program and open the image, again, sometimes that works, sometimes it doesn't. If that doesn't work, then it's clicking file-open and opening the image. That will work, but ctrl+o won't work. same dialogue but how I get to it seems to matter to krita.

 

For awhile I was getting CRC errors downloading things even though the files seemingly finished just fine. Diagnosing that issue is what lead to me changing from xmp2 to xmp1 profile in the uefi.

If anyone has any idea what might be going on here, I'd appreciate the help! At this point I'm starting to think it might be the CPU itself....

0 Kudos
2 Replies
herbms
Beginner
368 Views

Your experience sounds very similar to mine. I just came across this thread that I think you will find relevant: https://community.intel.com/t5/Processors/14900ks-unstable/m-p/1598250/highlight/true#M72486

 

TL;DR Limiting the all-core ratio to something at or below 5.9GHz seems to do resolve this (of course at the expense of reduced performance).

 

So far so good on my workloads that were previously extremely crash prone.

0 Kudos
Weatherby
Beginner
196 Views

Soo, the solution is to accept the botched hardware we purchased that can't function at stock frequencies and undervolt/clock it ourselves just to get stable and live that way?

No, I don't think that's the answer. Not one I paid $600 for anyway.

Not functioning at stock settings is a defect not a feature. If this is the case, then an RMA is most appropriate and a new chip that can function within the specs I paid for to replace the defective chip sent asap.

Thanks for pointing me to a known bug to include in my RMA request.

0 Kudos
Reply