Processors
Intel® Processors, Tools, and Utilities
14685 Discussions

Intel Extreme Tuning Utility not longer working properly for my 13600k after update

Ed24
Novice
951 Views

The speed optimizer feature was working fine before the latest intel Extreme Tuning Utility version 7.14.1.12.  I have followed all the previous suggestion is this forum including:

  1. Check XTU Version:

    • First, let’s verify that you’re using the latest version of XTU. To do this:
      • Open the Intel XTU.
      • Go to System Information.
      • Look for the XTU version. Ensure it’s 7.14.0.15 or later.
      • If not, download the latest version from the Intel XTU download page.
  2. Uninstall and Reinstall XTU:

    • Sometimes, a fresh installation can resolve compatibility issues.
      • Uninstall the current XTU version.
      • Reboot your system.
      • Download and install the latest XTU version from the link provided above.
  3. Reset BIOS to Default and Update BIOS:

    • Resetting BIOS settings to default can help.
    • Update your motherboard’s BIOS to the latest version. You can find the BIOS update on your motherboard manufacturer’s website.
  4. Registry Edit (Advanced):

    • If the issue persists, you can try the following advanced steps:
      • Open Registry Editor.
      • Navigate to HKEY_USERS\.DEFAULT\Software.
      • Create a new key named Intel under that node (if it doesn’t exist).
      • Create another new key named XTU under the Intel node (if it doesn’t exist).
      • Create a new DWORD value under the XTU node called LoggingLevel with a value of 4.

 

After all this, I still have the same issue.

0 Kudos
1 Solution
ACarmona_Intel
Moderator
788 Views

Hello Ed24,

 

Thank you so much for the response and for providing us with the details that we requested.

 

We wanted to inform you that 13600K/KF processor ISO support was not deliberately removed from XTU.

 

The issue was fixed with an updated XML file published on Download Centre on April 16, 2024. 

 

So please uninstall the older version (7.14) and re-install 7.14, available on DC, with a new XML. The version number did not change since the installer is the same, but you will see a fix and ISO available with suggested values.

 

Please let me know if the issue still persists, so we can take our next step.

 

Thank you, and have a great day ahead!

Best regards,
Carmona A.
Intel Customer Support Technician

View solution in original post

0 Kudos
6 Replies
ACarmona_Intel
Moderator
873 Views

Hello Ed24,


Thank you for posting in our communities.


To help me further identify the problem and offer you a solution, kindly provide the following details:


  • Please provide a screenshot or a photo of the exact issue that we have, and by the way, are there any error messages on the XTU explaining why the speed optimizer does not work?
  • What is the complete model of your processor?


We look forward to your response! 



Thank you, and have a great day ahead!


Best regards,

Carmona A.

Intel Customer Support Technician


0 Kudos
Ed24
Novice
861 Views

Ed24_0-1713292794213.png

 

* Please see screen shot above. It says the intel speed optimize 2.0 not supported. This feature was working fine before intel push the latest update 7.14.1.12.

 

* my processor is a 13th Gen Intel(R) Core(TM) i5-13600K

 

0 Kudos
ACarmona_Intel
Moderator
789 Views

Hello Ed24,

 

Thank you so much for the response and for providing us with the details that we requested.

 

We wanted to inform you that 13600K/KF processor ISO support was not deliberately removed from XTU.

 

The issue was fixed with an updated XML file published on Download Centre on April 16, 2024. 

 

So please uninstall the older version (7.14) and re-install 7.14, available on DC, with a new XML. The version number did not change since the installer is the same, but you will see a fix and ISO available with suggested values.

 

Please let me know if the issue still persists, so we can take our next step.

 

Thank you, and have a great day ahead!

Best regards,
Carmona A.
Intel Customer Support Technician

0 Kudos
ACarmona_Intel
Moderator
659 Views

Hello Ed24, 


We are checking in with you to know if you have already performed the troubleshooting steps that we have provided or if you have any additional queries. Please know that we would be happy to assist you if you have any.


Thank you, and have a great day!



Best regards, 

Carmona A.

Intel Customer Support Technician


0 Kudos
Ed24
Novice
634 Views

Hi,

Thank you so much for this follow up. The fix you suggested worked. The updated corrected the problem, and it is working as expected.

 

I am really grateful for how quickly this was resolved.

 

Thanks again,

Ed

ACarmona_Intel
Moderator
613 Views

Hello Ed24, 


Thank you so much for the response and for letting us know that our issue has been resolved.

 

We also wanted to express our gratitude for your great cooperation in resolving our problem. We will now close our case as the issue has already been resolved. If in the future you might need our assistance again, please submit a new question, as this thread will no longer be monitored. 

 

Thank you, and have a great day ahead! 



Best regards, 

Carmona A.

Intel Customer Support Technician


0 Kudos
Reply