Processors
Intel® Processors, Tools, and Utilities
14918 Discussions

Issues with Intel® Core™ i9 processor 14900KS

Heffy
Beginner
1,011 Views

I bought this top of the line processor along with a liquid cooler and Asus rog strix z970-e MB.  I have been having troubles with stability from day one and have followed many post online to try and get my system stable.  I finally found a config that runs stable in all my benchmarking (intel extreme tuning utility, cinebench, 7z benchmark) but gaming (enshourded,palword,starcitizen) is not stable at all.  I get random crash to desktop even when my logs show no high temps or volts or amps.  I'll post my config and perhaps someone can provide so assistance, but i think i need to rma this i9.

When i tried running it at 307a 253w and 253w it was not stable in all benchmarks.  in the bios i got the latest update and tried all the intel default settings but gaming is just not possible.  it seems everything crashes to desktop after about 30 of gaming.  I've been recording logs with the intel tool to see if the games are causing any peeks but i'm not seeing anything alarming.

0 Kudos
7 Replies
DaveGeerardyn
Beginner
920 Views

Could it be related to the i9 CPU bug?

According to the following link, your processor might also be affected...

https://arstechnica.com/gadgets/2024/04/intel-is-investigating-game-crashes-on-top-end-core-i9-desktop-cpus/

0 Kudos
Heffy
Beginner
860 Views

I've did more research and I thought the same thing as well.  I got some info from my bios screen but every change I make does not seem to Help.  The only thing i have not tried it the ac and dc load line; i'm not sure what mine should be for the 14900ks any help would be appreciated, or can intel tell me how to start an rma for this?

i9 part5.JPG

0 Kudos
Heffy
Beginner
794 Views

I was able to try some new power setting that got me 1 hour of enshrouded before a crash to desktop, and I should mention a we aw snaps from chrome. i went to 240w for long and short and a limit of 280a

I think i got a defective cpu, how do i start this rma process intel?

i9 part6.JPG

0 Kudos
JeanetteC_Intel
Moderator
772 Views

Hello Heffy,


Thank you for posting in Intel Communities.


We understand that you have already completed a lot of testing and checking and the issue has not been resolved. We hope to confirm if the Intel default settings you mentioned being tried, in your original post, are the same settings found on this link.


We will wait for your reply, so we can proceed with helping you with on RMA process.



Best regards,


Jeanette C.

Intel® Customer Support Technician


0 Kudos
Heffy
Beginner
701 Views

Yes i can confirm with my settings set to those and using the 307 iccmax and the 253 pl1 and pl2 the system is not stable.  Web browsers barely work and games crash.  I even have trouble extracting files from a compressed folder.  Only when I set the iccmax and pl1 and pl2 lower can i get more stable but everything still crashes after some use even then.

0 Kudos
Heffy
Beginner
543 Views

FYI found a more stable config for gaming, however other apps are still crashing randomly.  Its clocked lower than every spec it should run on.

i9 part7.JPG

0 Kudos
JeanetteC_Intel
Moderator
448 Views

Hi Heffy,


Kindly check your email on how to proceed with claiming a warranty.



Best regards,


Jeanette C.

Intel® Customer Support Technician



0 Kudos
Reply