Processors
Intel® Processors, Tools, and Utilities
14671 Discussions

i9-12900HX BSODs on restart (and sometimes on sleep) if max cache ratio is decreased

vg_vassilev
Beginner
1,356 Views

Hello.

I have been exploring undervolting my i9-12900HX on my recently bought Lenovo Legion 7i Gen 7. I've read a lot of topics and guides, and I think by now I have a general idea of what's going on and managed to achieve some nice results, reducing temperatures and power draw and increasing the sustained clocks.

I started my journey in undervolting using Throttlestop, but the issue described below is also present when using XTU (which I've tried unintsalling and re-installing it a few times, just in case), but it doesn't seem to be related to either XTU or Throttlestop.

When I first started undervolting, I immediately faced crashes when I tried to adjust the P cache voltage offset. This is resolved by dropping the max cache ratio to 36 (discussed in various topics online). The default max cache ratio is 46 and I can confirm it is reached - the ring clock does get up to 4.6Ghz from time to time, though it sticks to 3.6GHz when the E cores are active.

Even though the default max cache ratio is 46, manually setting it to above 36 in Throttlestop or XTU, causes an immediate crash.

If the max cache ratio is not decreased to 36, just checking a box that unlocks the adjustable offset for the P cache ratio (in Throttlestop) causes an immediate crash; and just applying any voltage offset to the cache voltage from XTU, even a symbolic -1mV, again causes a crash.

The max cache ratio can be set per profile in Throttlestop, and if I have the undervolted profile with cache ratio set to 36 selected and active, and then try switching to a completely default profile (no undervolts, no changes, nothing) where the max cache ratio is the default 46, the crash is instant. However, if I also set the cache ratio of this default profile to 36, it switches without issues and the undervolt is removed, working as expected.

After lots of testing, I reached a stable undervolt for the P cores and P cache with the max cache ratio set to 36. I haven't tried setting any offsets for the system agent, E cache or the rest, as it doesn't seem it will bring me any noticeable benefit but it might cause instability. The CPU is perfectly stable with the undervolt I've set in all kinds of sustained benchmarks, Prime95 small FFTs torture test, games, idle, light usage, etc.

The problem comes when the laptop tries to go to sleep or I restart, and this problem are all related to the max cache ratio being changed from 46 to 36 (which as mentioned, is unfortunately 100% necessary if I were to apply any undervolt to the cache).

a) Sleep issues - sometimes the PC fails to go to sleep and reboots immediately; sometimes it goes to sleep and crashes upon waking up; sometimes it manages to wake up once, but crashes after I put it to sleep again. It cannot complete 3 full sleep-resume cycles without showing a BSOD. The BSODs I get are various with different kind of bugcheck codes.

b) Restart issues - this is my bigger problem, as I could easily disable sleep and get on with it. However, I cannot acccept to use a PC that cannot be restarted properly:

Just the action of decreasing the max cache ratio to 36, even without any other changes or undervolts being applied (and regardless of whether XTU or Throttlestop is used), causes a BSOD during boot on every single restart attempt.
The error is almost always (if not always) "UNEXPECTED_KERNEL_MODE_TRAP".

It's very important to stress that the problem manifests only when the E cores are enabled.

With them disabled, I can do whatever I want with the P cores, even leave the max cache ratio at 46 (default) and as long as the undervolt is stable, there are no crashes under any circumstances. This is how I currently have my laptop set up as the performance and thermals with just the P cores active, and my stable undervolt applied, is quite satisfactory.

I've did a sfc and DISM scans/repairs, but they didn't resolve the above issue.
In Throttlestop there are options that default the voltage and cache ratio (two separate options) when the PC goes to sleep - I've tried enabling them, each one separately as well as both together, but they don't resolve the issue.
I tried outright disabling the hybernation via CMD, using the command powercfg.exe /h off, as I read this might be causing weird issues - didn't help.
I tried resetting the BIOS to default settings.

Otherwise, the laptop operates without hiccups and there are no problems when the E cores are enabled and the max cache ratio is at the default 46, but the moment it is decreased the issues begin. I would have understood if increasing it caused problems, but it's extremely strange that decreasing it causes BSODs on every single restart attempt.

I've linked three minidumps below:
https://drive.google.com/drive/folders/1nt9A0oxm_EDqorOBNgy0Hw-aTQ3vug0N?usp=sharing

I would appreciate any advice and help.

Best regards,
Vassil

0 Kudos
8 Replies
vg_vassilev
Beginner
1,209 Views

Hope I can receive a reply from the Intel support team regarding this. Still unable to decrease cache ratio while E cores are active, without causing BSODs on every restart.

0 Kudos
ACarmona_Intel
Moderator
1,126 Views

Hello Vg_vassilev, 


Thank you for posting in our Intel communities.


To help me further identify the problem and offer you a solution, kindly provide the following details:


  • When did you purchase the unit?
  • Was it working fine before?
  • Did you change any settings before the issue started?
  • What are the troubleshooting steps that you tried? Please provide the brand and model of your board and other components used for testing.


Thank you, and have a great day ahead!



Best regards,

Carmona A.

Intel Customer Support Technician


0 Kudos
vg_vassilev
Beginner
1,087 Views

Hello, Carmona,

Thank you for looking into this, appreciate it!

- I purchased the laptop in the first half of February.
- It has been and is working fine but thermals under load are not perfect, so I wanted to improve on this by applying a slight undervolt.
- I have not changed anything else, just setting offsets to the voltage of the CPU cores and cache.
- As mentioned, it's a laptop but here is the information from CPU-Z:

Motherboard: LNVNB 161216
BIOS: K1CN45WW (latest one, but I've tried with an older one too - mentioned below)
RAM: 2x16GB SK Hynix DDR5-4800 - no overclock, default SPD profile
GPU: RTX 3080 Ti 16GB

- With all 16 cores (P+E) active, the laptop is working perfectly fine with a voltage offset to the CPU core only. Currently I have it set to -70mV and validated its stability through various testing.

- With all 16 cores active, I get a BSOD the moment I try applying any voltage offset to the P cache (even a symbolic -1mV). This topic has been discussed in many topics online and other users found that decreasing the max cache ratio to 36 prevents those BSODs when a voltage offset is applied.
- With just the 8 P cores active, I can apply an undervolt to the P cache without adjusting the max cache ratio, and it's working okay.

Main problem:

With the max cache ratio decreased to 36, the P+E 16-core configuration can reach a nice and stable undervolt on both the CPU core and P cache, and I see good results with the temperatures and clock speeds under load, but:
- sleep is inconsistent (blue screens from time to time)
- a blue screen is 100% guaranteed during boot on every restart attempt. Then it restarts by itself and runs normally, and I can re-apply the undervolt and decreased max cache ratil, and use the laptop without a problem.. until I have to restart it.

The issue is exactly the same regardless of whether I use XTU or Throttlestop to apply the voltage offsets and decrease the max cache ratio.

Troubleshooting attempted:

- I did a sfc /scannow run and and a DISM automatic repair, which fixed the shift+delete shortcut on my external keyboard, but nothing else.
- In Throttlestop there is functionality to default the voltage and cache ratio (two separate options) when the PC goes to sleep - I've tried with both disabled, both enabled and each one enabled by itself, but nothing resolves the problem.
- Tried with the "fast startup" option enabled in Windows, and with it disabled.

- Disabled hybernation via CMD, using the command powercfg.exe /h off, as I read this might be causing weird issues - didn't help.
- R
esetted the BIOS to default settings.
- Tried with the laptop in hybrid GPU mode and in dGPU mode.
- The last thing I tried two days ago was reverting to an older BIOS - KNCN31WW, which allows undervolting even with virtualization enabled in the BIOS, but the problem with restarts still remains the same.

0 Kudos
vg_vassilev
Beginner
1,106 Views

Hello, Carmona,


Thanks for looking into this!


- I purchased the laptop in the first half of February.
- It has been and is still working fine, but I wasn't happy with the temperatures under load and I wanted to improve on this by applying a slight undervolt.
- I haven't changed any other settings, just what I've mentioned.
- The unit is a laptop, but here is the info from CPU-Z:

Motherboard: LNVNB 161216
BIOS: K1CN45WW (latest one, but I also tried reverting to an older one - more details below)
RAM: 2x16GB SK Hynix DDR5-4800 - no overclock, stock profile
GPU: RTX 3080 Ti

I'm using Windows 11 Pro.

- With all 16 P+E cores enabled, applying voltage offset to the CPU cores only works as expected and I've managed to achieve a stable -70mV undervolt, validated through various testing.

- With all 16 P+E cores enabled, applying voltage offset to the CPU cache (even a symbolic -1mV) causes an immediate BSOD. This is discussed in many topics online related to the exact same processor (i9-12900HX) and other users have discovered that decreasing the max cache ratio to 36 resolves this immediate crash.

- With just the 8 P cores enabled, undervolting the CPU cache works without the need to decrease the max cache ratio. There are no problems whatsoever.

- With all 16 P+E cores enabled and the max cache ratio decreased to 36, undervolting the CPU cache works as expected and greatly improves temperatures under load. It is also perfectly stable at -60mV on my machine, under any kind of heavy or mixed load, or in idle.
Problem:
- sleep is inconsistent (BSODs from time to time)
- a BSOD is 100% guaranteed during boot from a restart, if the max cache ratio has been decreased in Windows before the restart is attempted.
- The issue is the same regardless of whether XTU or Throttlestop is used to apply the decrease in max cache ratio and the voltage offsets.

Troubleshooting attempted:

- Did a sfc scan and a DISM repair.
- In Throttlestop there is functionality to default the voltage and cache ratio (two separate options) when the PC goes to sleep. I've tried with both enabled, both disabled, and each one enabled separately.
- I tried disabling the hybernation via CMD, using the command powercfg.exe /h off, as I read this might be causing weird issues - didn't help.
- Disabled fast startup in Windows.
- Tried with the laptop being in hybrid GPU mode and in dGPU mode.

- I tried resetting the BIOS to default settings.
- The last thing I tried two days ago was flashing back an older BIOS - K1CN31WW, which allows undervolting in OS even with virtualization enabled in BIOS, but this also didn't help. I then restored the latest bios again, as it contains security patches.

0 Kudos
ACarmona_Intel
Moderator
976 Views

Hello Vg_vassilev, 


Thank you so much for the response.

 

Please try the troubleshooting steps outlined on this link below:


If the issue still persists after trying out the provided troubleshooting steps, please let me know.


Thank you, and have a great day ahead!


Best regards,

Carmona A.

Intel Customer Support Technician


0 Kudos
ACarmona_Intel
Moderator
902 Views

Hello Vg_vassilev, 


We are checking in with you to see if you have already performed the recommendations that we have provided or if you have any additional queries or require further explanation. Please know that we would be happy to assist you if you have any questions.


Thank you, and have a great day!


Best regards,

Carmona A.

Intel Customer Support Technician

 


0 Kudos
ACarmona_Intel
Moderator
751 Views

Hello Vg_vassilev, 


We are checking in with you, as we have not heard any response from you. 


Thank you, and have a great day!

 

Best regards, 

Carmona A.

Intel Customer Support Technician


0 Kudos
ACarmona_Intel
Moderator
713 Views

Hello Vg_vassilev, 


We have not heard back from you, so we will close this enquiry now. If you need further assistance, please submit a new question, as this thread will no longer be monitored.

Thank you, and have a great day ahead.


Best regards,
Carmona A.
Intel Customer Support Technician

0 Kudos
Reply