Rapid Storage Technology
Intel® RST, RAID
Announcements
The Intel sign-in experience is changing in February to support enhanced security controls. If you sign in, click here for more information.
1866 Discussions

How to change from RAID0 to AHCI

idata
Employee
1,777 Views

Hello there. I have couple question. I tried google but was not successful.

I have Windows XP, BIOS set to RAID, 2 HDD, running Intel RST (Latest driver). and running fine.

Mobo is Gigabyte GA-EP35-DS3R (P35 / ICH9R)

I need to change 2 HDD RAID to 1 HDD AHCI mode.

I managed cloning 2 HDD RAID volume to 1 HDD, and Windows XP starts just fine under BIOS set to RAID.

But when I change BIOS to AHCI mode, I get 0x7B BSOD.

These are my question.

(1) How do I change Windows XP to RAID mode to AHCI mode?

(2) Any disadvantage if I keep using RAID mode in 1 HDD configuration?

Thank you!

Matthew K

0 Kudos
2 Replies
idata
Employee
481 Views

Since no one answer to my questions, I googled more and tried to fix myself and I managed to fix 0x7b BSOD.

Here is what I did.

I basically followed his advice.

http://forums.pcper.com/showthread.php?t=444831 http://forums.pcper.com/showthread.php?t=444831

I had iaStor.sys in RAID mode, my registry was like this.

 

==== My original registry ====

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\pci# ven_8086&dev_2822&cc_0104]

 

"ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"

 

"Service"="iaStor"

 

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\iaStor]

 

"Type"=dword:00000001

 

"Start"=dword:00000000

 

"Group"="SCSI miniport"

 

"ErrorControl"=dword:00000001

 

"DisplayName"="Intel RAID Controller"

 

"ImagePath"=hex(2):73,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,5c,00,44,00,\

 

52,00,49,00,56,00,45,00,52,00,53,00,5c,00,69,00,61,00,53,00,74,00,6f,00,72,\

 

00,2e,00,73,00,79,00,73,00,00,00

 

"Tag"=dword:00000019

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\iaStor\Parameters]

 

"queuePriorityEnable"=dword:00000000

 

"BusType"=dword:00000008

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\iaStor\Parameters\Port0]

 

"AN"=dword:00000000

 

"LPM"=dword:00000000

 

"LPMSTATE"=dword:00000000

 

"LPMDSTATE"=dword:00000001

 

"GTF"=dword:00000000

 

"DIPM"=dword:00000000

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\iaStor\Parameters\Port1]

 

"AN"=dword:00000000

 

"LPM"=dword:00000000

 

"LPMSTATE"=dword:00000000

 

"LPMDSTATE"=dword:00000001

 

"GTF"=dword:00000000

 

"DIPM"=dword:00000000

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\iaStor\Parameters\Port2]

 

"AN"=dword:00000000

 

"LPM"=dword:00000000

 

"LPMSTATE"=dword:00000000

 

"LPMDSTATE"=dword:00000001

 

"GTF"=dword:00000000

 

"DIPM"=dword:00000000

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\iaStor\Parameters\Port3]

 

"AN"=dword:00000000

 

"LPM"=dword:00000000

 

"LPMSTATE"=dword:00000000

 

"LPMDSTATE"=dword:00000001

 

"GTF"=dword:00000000

 

"DIPM"=dword:00000000

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\iaStor\Parameters\Port4]

 

"AN"=dword:00000000

 

"LPM"=dword:00000000

 

"LPMSTATE"=dword:00000000

 

"LPMDSTATE"=dword:00000001

 

"GTF"=dword:00000000

 

"DIPM"=dword:00000000

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\iaStor\Parameters\Port5]

 

"AN"=dword:00000000

 

"LPM"=dword:00000000

 

"LPMSTATE"=dword:00000000

 

"LPMDSTATE"=dword:00000001

 

"GTF"=dword:00000000

 

"DIPM"=dword:00000000

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\iaStor\Parameters\oromVersion]

 

"MajorVersion"=dword:00000007

 

"MinorVersion"=dword:00000005

 

"HotfixNumber"=dword:00000000

 

"BuildNumber"=dword:000003f9

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\iaStor\Enum]

 

"0"="PCI\\VEN_8086&DEV_2822&SUBSYS_B0001458&REV_02\\3&13c0b0c5&0&FA"

 

"Count"=dword:00000001

 

"NextInstance"=dword:00000001

==== End of Registry ====

I deleted these registry and merged registry from website at above.

==== New registry ====

 

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\CriticalDeviceDatabase\pci# ven_8086&dev_2922&cc_0106]

 

"Service"="iaStor"

 

"ClassGUID"="{4D36E96A-E325-11CE-BFC1-08002BE10318}"

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\iaStor]

 

"Type"=dword:00000001

 

"Start"=dword:00000000

 

"Group"="SCSI miniport"

 

"ErrorControl"=dword:00000001

 

"ImagePath"="system32\\drivers\\iaStor.sys"

 

"tag"=dword:00000019

 

"DisplayName"="Intel AHCI Controller"

<span sty...

idata
Employee
481 Views

I fixed myself. I commented what I did.

Reply