Rapid Storage Technology
Intel® RST, RAID

RMS25PB080 broken ?

bonechi
Beginner
661 Views

When I power-cycled a server which used RMS25PB080 (Intel raid controller), the following message shows up;

"RAID Adapter
Firmware Failed Validation!!!
Adapter needs to be reflashed.
Press Any Key to Continue..."

I didn't touch the firmware of the raid controller at all. I bought this server 10 years ago and it was working until recently. I'm wondering if it is broken and I should give up server data ?

0 Kudos
14 Replies
Steven_Intel
Moderator
631 Views

Thank you for posting on the Intel️® communities. 


In order to further assist you, the team in charge will get back to you soon.


Best regards,


Steven G.

Intel Customer Support Technician.


Paul_R_Intel
Moderator
627 Views

Hello bonechi,


I hope you are doing great, we understand that you have a "Firmware Failed Validation!!!" POST message. Lets get this resolve.


Have you tried to re-flash the firmware to mitigate the issue? if not please try the following steps:



You can find the latest firmware here:



Please let us know the outcome.


Best regards,



Paul R.  

Intel Customer Support Technician  

For firmware updates and troubleshooting tips, visit:  

https://intel.com/support/serverbios  


bonechi
Beginner
569 Views

Hi Paul,

 

Many thanks for suggesting to re-flash the firmware of the raid card.

I downloaded the firmware successfully and extracted it to a USB memory formatted with FAT32.  I plugged the USB to the PC and restarted it again. I was able to go to a EFI Shell prompt after some operations. I moved to the USB directory by typing "fs0:" and  I executed "update.nsh". The command might work, but the following messages were returned:

HA-0 (Bus 5 DevFn 0)

HA-0 is not supported. Firmware Initialization failed.

 

Is there anything else I can do?

If my RAID adapter might be broken and I replaced it with a new same card, it would work? By the way my server is one of the Intel Server System P4000CP Family.

 

Best regards,

 

Bonechi

 

Paul_R_Intel
Moderator
547 Views


Hello bonechi,


I hope you are doing great,


Thanks for all the information provided, please let me investigate further and we will get back to you.


Best regards,



Paul R.  

Intel Customer Support Technician  

For firmware updates and troubleshooting tips, visit:  

https://intel.com/support/serverbios 



Paul_R_Intel
Moderator
533 Views

Hello bonechi,


I hope you are doing great,


Thanks for your patience and time, would it be  possible to get and attach the raid log? You can try these steps:



You can try the storcli step:


  • storcli /call show AliLog logfile=raidlog.tx

 


If the storcli doesn't work, try using the cmdtool2.



CmdTool2 –AdpAliLog –aAll –NoLog > saslog.txt.


 I will be waiting for your reply.

 

Best regards,


Paul R.  

Intel Customer Support Technician  

For firmware updates and troubleshooting tips, visit:  

https://intel.com/support/serverbios 


bonechi
Beginner
488 Views

Hello Paul,

 

Thank you very much for helping me carefully.  I tried two methods as you suggested, but only empty files were created for both cases. And I found that "storcli.log" was created in the case of "STORCLI". I attach it with this reply, and it might contain some hints. I am afraid I was doing something wrong.

I think the situation of my server may become worse. Last time I said the message as "HA-0 (Bus 5 DevFn 0) ..." had returned when I executed "update.nsh", but no message returned when I tried it again this time. I might be better to get another RMS25PB080 and replace the present one.

 

Best regards,

 

Bonechi

Paul_R_Intel
Moderator
472 Views

Hello bonechi,


I hope you are doing great,


Thanks for all the information provided, please let me investigate further and we will get back to you.


Best regards,



Paul R.  

Intel Customer Support Technician  

For firmware updates and troubleshooting tips, visit:  

https://intel.com/support/serverbios 


Paul_R_Intel
Moderator
457 Views

Hello bonechi,


I hope you are doing great,


Thanks for the patience and time, upon review from storcli.log we can see the command is correct and the tool did find the controller but the output is empty, it looks like the controller is no longer in functional state.


  • Tue Dec 13 03:27:47 2022: CliUefiMain::ShellAppMain processing for command=/ call show AliLog logfile=raidlog.txt 
  • Tue Dec 13 03:27:47 2022: EfiControllerExplorer::explore_PCI - Bus:5 Device:0 Function:0 Segment:0 VendorId:0x1000 DeviceId:0x5B Index:0 BaseAddress:0xFFFFFFFFD0D40000 AdapterStatus:0


Without the log output, we have no clue what may have caused the failure and if the RAID volumes are intact.


 We agree that you may need to find another RMS25PB080 to replace it with. Alternatively, RS25AB080 or RS25DB080 are also functionally equivalent to his current controller


Though, it may be difficult to find these controllers as they have been discontinued for a long time.


In case you have any issues finding the parts here you have our list of Intel Authorized Retailers:



Please let us know if there is anything else that we can do for you.


Paul R.  

Intel Customer Support Technician  

For firmware updates and troubleshooting tips, visit:  

https://intel.com/support/serverbios 



bonechi
Beginner
451 Views

Hello Paul,

 

I appreciate your kind supports. I understand my RS25PB080 will not work. I will try to find another RMS25PB080 (or compatible ones) and try to replace the present one with it. I don't know whether the RAID volumes are intact or not, but I would like to try to do.

Many thanks for investigating the log too.

 

Best regards,

 

Bonechi

Paul_R_Intel
Moderator
430 Views

Hello bonechi,


I am glad to hear from you, thank you for all the details provided and working on getting all the info requested, do not hesitate to contact us back if you need further support. for now is it ok if we mark the thread as resolved?


Best regards,


Paul R.  

Intel Customer Support Technician  

For firmware updates and troubleshooting tips, visit:  

https://intel.com/support/serverbios 


Paul_R_Intel
Moderator
347 Views

Hello bonechi,


I hope you're doing great, we would like to follow up on your thread, please let us know if there is anything else we can do for you?


If we do not hear back from you we will close the thread on the 23rd.


Best regards,


Paul R.  

Intel Customer Support Technician  

For firmware updates and troubleshooting tips, visit:  

https://intel.com/support/serverbios 






bonechi
Beginner
337 Views

Hello Paul,

 

Thank you very much for following me and the thread. I found a very cheap secondhand card and ordered it. It will take several weeks for it to reach me because it comes from abroad. If this thread may remain until the time when I will replace the broken one with a "new" secondhand one, I will report the result, but I think a new technical question will not arise. If you have to close the thread or you don't want to keep a silent thread for a long time, I'm not against closing the thread.

 

Best regards,

 

Bonechi

Paul_R_Intel
Moderator
311 Views

Hello bonechi,


I hope you are doing great, thank you for the update I am glad to know you are getting a replacement, as the time is not certain, we rather archive the thread but please hit us back if any further support is needed once it gets delivered.


We appreciate your patience and time.


Best regards,


Paul R.  

Intel Customer Support Technician  

For firmware updates and troubleshooting tips, visit:  

https://intel.com/support/serverbios 


bonechi
Beginner
172 Views

Dear Paul,

 

I have replaced the broken card with the other one which I bought, and it works fine. The RAID volumes seem to be intact. I thank you very much for your kind suggestions. You helped me a lot.

 

Best regards,

 

Bonechi

Reply