Solid State Drives (NAND)
Support for Issues Related to Solid State Drives based on NAND technology
This community is designed for sharing of public information. Please do not share Intel or third-party confidential information here.
3783 Discussions

160GB 320 series w/8MB crash - can't unlock security freeze - HELP!


My computer froze solid while I was making an online purchase, and the only way to get out of it was to force a power down. When I turned it on again, I had an invalid partition table, and my computer reported my 160GB Intel 320 series SSD as 8MB with an invalid partition table. After several days of unsuccessfully trying everything I could think of to get the data of it, I stumbled upon an article about the Intel 320 series firmware bug. Ugh.

When I look at the disk with a hex editor, I see almost all zeros, but my mind won't accept that since my last backup was over a month ago. I tell myself I'm only seeing 8MB of the drive - a small corner that happens to be all zeros. Am I in denial?

After much pain, I finally figured out how to make one of my spare SATA hard drives boot externally while plugged into a USB slot via an adapter. That allowed me to keep the damaged SSD in the internal SATA port so I could use the Intel SSD Toolbox. I didn't get me very far, though, because there is a security freeze lock on the drive, and nothing I've tried can turn it off. I've hot unplugged/replugged the SSD (it's a Thinkpad T420), disabled/enabled the SSD driver (from Microsoft), hibernated the computer ("sleep" is disabled because my notebook's native video driver isn't installed) - nothing works. When I boot without the SSD then hot plug it in, the Toolbox doesn't see it. Someone here posted that he got the security freeze lock off using Linux tools, but he didn't give specifics. I have a Ubuntu Live CD, but I have no idea what Linux tools he used or how he did that.

I'm not that keen on doing a secure erase, anyway, because then there's no hope whatsoever of recovering any data from the drive. Is there any other way to get my drive back to its original 160GB short of Secure Erase? Nothing else works unless the drive correctly reports its size. When I tried to use the Firmware Update Tool to update the firmware, it said I already had the most recent firmware (not true). Same with the Toolbox. I can't update the firmware with the drive in its current state.

I've been very dismayed to see all the recent, post-firmware-update reports of new 8MB firmware bug crashes. Clearly the bug hasn't been fixed, despite Intel's claims. Even before I knew that, and before I knew my problem was this firmware bug, I had decideed I would never again use an SSD as the main drive on my work computer. But if the Intel 320 series has an unfixed firmware bug that causes repeated crashes, I don't want to use it at all for anything. If I have to send this SSD into Intel under warranty, I either want a refund (first choice), or a different type of drive.

Also, the error message I'm getting is slightly different from that in the Intel announcement. I have BAD_CTX, but the number is not 0000013, it's 00000159 - though the error did occur when I had to force a power down (due to a frozen computer). That makes me even more unsure that the 8MB bug is fixed by the latest firmware.

All this leads me to three questions:

1. Is there any hope of getting my data off this drive? If so, how?

2. How do I unlock the security freeze lock on the drive?

3. Where are these mysterious Linux tools for bringing drives hit with this bug back to life?

Thanks in advance.

P.S. When I registered for this forum, I requested a username that was not my full first and last name, so how did I end up with my full first and last name in the forum?? Can someone change this for me?

0 Kudos
3 Replies
New Contributor II

As PseudoKirby also posted in another thread, Gillware claims to be able to recover Intel x25/320 series 8mb bug data for an unspecified price. It most likely involves sending in the drive. Since they initially posted in this forum, I haven't head of anyone trying them, so I can't vouch from them.

Regarding you full name being shown in the discussions: Don't worry, it isn't. I see "permutations". It's only when you are logged in you (and only you) see your full name.


Gillware appears to have a bit of a scam going, unfortunately. Their home page offers a "free online estimate". You have to enter your email address and phone number. I fell for this. Of course, there is no online estimate. Once they've gotten this information from you, they ask you to call them to "submit a case".

30 seconds after I gave them my phone number, the phone rang. I said I didn't want to do business with them because of the underhanded way in which they obtained my contact information. It was too sneaky.

I don't trust a company that does business like that. I'm sure they'd charge a fortune to get data off the drive - if they even could. They'd probably charge me a fortune to tell me they can't. I looked at the drive with a hex editor, and it's all zeros. How do you get data from zeros?


I realise that this reply comes a bit late. But for the benefit of others who may run into the same problem I want to report that I have in fact had data from a 160 GB Intel 320 series drive with the 8 MB bug recovered by Gillware, and at a very reasonable cost compared to the prices charged by other data recovery companies - who couldn't do the job. Apart from shipping it doesn't even cost anything to have them check a defective drive.

And I should say that when dealing with their customer representatives they have been nothing but pleasant, helpful, and professional. If a crashed 320 series drive contains anything of value I would definitely recommend that data recovery is attempted rather than just wiping the drive, which seems to be the standard recommendation from many people.