Solid State Drives (NAND)
Support for Issues Related to Solid State Drives based on NAND technology
This community is designed for sharing of public information. Please do not share Intel or third-party confidential information here.
3783 Discussions

How do I troubleshoot "Data mismatch error" in Intel SSD Toolbox 3.1.2 for 480GB SSD (Series 520)

Community Manager

520 480gbHi I have bought 2 "Intel SSD 520 Series 480GB". When I run the Quick Diagnostic Scan and Full Diagnostic Scan they both report an error for the Data Integrity test:"Error: Data mismatch detected. Contact your reseller or local Intel representative for assistance".

Can anyone advise how to further troubleshoot this problem? There does not seem to be any error output in the form of a log file, etc that I can find.

This is occuring for both drives, and I find it difficult to believe that my luck is that bad with 2 new SSDs.

The place that sold me the 2 SSDs (which is still waiting 3 months for new stock to come in with again the date eing delayed, which makes me wonder if there is a problem with this model) told me that the Intel SSD Toolbox 3.1.2 reports false errors so I should not be concerned. But I cannot trust that information as I have not seen it elsewhere on the net.

Sometimes the Quick Diagnostic Scan does complete without errors. But I think (I have to test more times) that for o9ne of the SSDs the Full Diagnostic Scan stops at 64% with the error, so that would seem like a genuine problem.

Any help, suggestions would be helpful. (For example I have seen one post where removing RAM seemed to solve trhe problem.) What could be going wrong? How does the test work? Could I have faulty RAM?

I am running it on a Lenovo W520 with 32GB of RAM (Corsair).



0 Kudos
4 Replies
Community Manager

Yeah, I ran across similar posts that indicate that the RAM was bad in some ways. Are you sure the right drivers are being loaded? For example, msahci, RAID. It depends on the RAID controller what driver you need, as long as you're using RAID. If the drives aren't in a RAID array you would be better off using the msahci driver. If you have an Intel RAID ROM on your board, you could use the Intel Rapid Storage drivers.

Have you stress tested components (Prime95, memtest, Windows Memory Diagnostic, etc)?

Community Manager


No RAID being used. No Intel RST. So purely Windows 7 x64.

I am running only 1 SSD off my W520. I plugged the 2nd one in to see what SSD Toolbox would report.

I suppose that I should try both SSDs on another computer. I have a workstation with 48GB of ECC RAM and 2 Xeons.

I have run Windows Memory Diagnostic (Extended tests) for a while without problems.

Will report with what I find to try to isolate the problem.

I just wish the SSD Toolbox provided more detail. I am not convinced of it's "accuracy".

I wonder how many people that use it have it reporting problems...

Community Manager

Early yesterday, you might have convinced me that toolbox has problems (I started posting here about a problem I have that I thought might be related to that toolbox, but no). But there's another guy/gal posting a similar issue (data mismatch) and it turns out the problem was a setting in BIOS related to memory. In that case, the voltage to RAM had to be increased, and that solved the problem. Not saying your is identical.

I believe I can say this: if your system otherwise runs fine, some hardware component(s) is(are) not playing nice(ly). So, how does your system run?

Tracking this down is gunna be a nightmare. Keep us posted.

Community Manager

Hello Platypus, on this case what I can tell you is that the error that you are describing could be related with many different causes, but we have noticed is that the data mismatch detected error is related with R.A.M memory and SATA controller miscommunication errors on most of the cases.

I suggest you to update your BIOS of your system to the latest version use the latest SATA drivers, perform a memory test to confirm that the R.A.M is working properly and you can try also to remove one dim of memory or use the minimum memory for your system and test the Solid State Drive again.