Solid State Drives (NAND)
Support for Issues Related to Solid State Drives based on NAND technology
3778 Discussions

Intel SSD 520 - problem after resume from sleep mode

Community Manager


i upgrade Asus ntb UL30VT with Intel SSD 520 120GB.

After try to "hibernate-ram" ntb going succesfully to hibernation, but when i try resume,

system resume ok, but disk is gone away from system.

Filesystem is not availible and write SIGBUS errors (in /var/log/messages i have lot's of messages that you cant write to system etc).

In previous same system i have OCZ Octane S2 SSD without problem, i only copy system to new disk.

I use Gentoo linux, I try severals kernel (vanila, gentoo-sources, tuxonince, reinstaling and reconfigure hibernate-scripts, try disable AHCI access. etc..)

I found that exists lots'of users that have similar (or same) problem on other operatin systems, for example:

you can search more with google (intel ssd "resume from sleep" problem)

I have actual firmware.

It seems that is problem of harddrive, I think right now then returned as a claim.

Have anyone solution on similar problem?

Thanks Zdenek



# smartctl -i /dev/sda


smartctl 5.42 2011-10-20 r3458 [x86_64-linux-3.0.26-tuxoniceasusUL30] (local build)


Copyright (C) 2002-11 by Bruce Allen,



Model Family: Intel 520 Series SSDs


Device Model: INTEL SSDSC2CW120A3


Serial Number: CVCV2--CENSORED---

LU WWN Device Id: 5 001517 bb27fb0e0


Firmware Version: 400i


User Capacity: 120 034 123 776 bytes [120 GB]


Sector Size: 512 bytes logical/physical



BIOS Information


Vendor: American Megatrends Inc.


Version: 210


Manufacturer: ASUSTeK Computer Inc.


Product Name: UL30VT


# emerge --info


Portage (default/linux/amd64/10.0/desktop/kde, gcc-4.5.3, glibc-2.14.1-r2, 3.0.26-tuxoniceasusUL30 x86_64)




System uname: Linux-3.0.26-tuxoniceasusUL30-x86_64-Genuine_Intel-R-_CPU_U7300_@_1.30GHz-with-gentoo-2.1

# hdparm -t /dev/sda



Timing buffered disk reads: 730 MB in 3.00 seconds = 243.18 MB/sec




5 Reallocated_Sector_Ct 0x0032 100 100 000 Old_age Always - 0


9 Power_On_Hours_and_Msec 0x0032 000 000 000 Old_age Always - 894830h+14m+44.020s


12 Power_Cycle_Count 0x0032 100 100 000 Old_age Always - 71


170 Available_Reservd_Space 0x0033 100 100 010 Pre-fail Always - 0


171 Program_Fail_Count 0x0032 100 100 000 Old_age Always - 0


172 Erase_Fail_Count 0x0032 100 100 000 Old_age Always - 0


174 Unexpect_Power_Loss_Ct 0x0032 100 100 000 Old_age Always - 62


184 End-to-End_Error 0x0033 100 100 090 Pre-fail Always - 0


187 Uncorrectable_Error_Cnt 0x000f 100 100 050 Pre-fail Always - 3057045


192 Power-Off_Retract_Count 0x0032 100 100 000 Old_age Always - 62


225 Host_Writes_32MiB 0x0032 100 100 000 Old_age Always - 4785


226 Workld_Media_Wear_Indic 0x0032 100 100 000 Old_age Always - 65535


227 Workld_Host_Reads_Perc 0x0032 100 100 000 Old_age Always - 20


228 Workload_Minutes 0x0032 100 100 000 Old_age Always - 65535


232 Available_Reservd_Space 0x0033 100 100 010 Pre-fail Always - 0


233 Media_Wearout_Indicator 0x0032 100 100 000 Old_age Always - 0


241 Host_Writes_32MiB 0x0032 100 100 000 Old_age Always - 4785


242 Host_Reads_32MiB 0x0032 100 100 000 Old_age Always - 1259


249 NAND_Writes_1GiB 0x0013 100 100 000 Pre-fail Always - 95h



# hdparm -i /dev/sda


Model=INTEL SSDSC2CW120A3, FwRev=400i, SerialNo=CVCV2--------------


Config={ Fixed }


RawCHS=16383/16/63, TrkSize=0, SectSize=0, ECCbytes=0


BuffType=unknown, BuffSize=unknown, MaxMultSect=16, MultSect=16


CurCHS=16383/16/63, CurSects=16514064, LBA=yes, LBAsects=234441648


IORDY=on/off, tPIO={min:120,w/IORDY:120}, tDMA={min:120,rec:120}


PIO modes: pio0 pio3 pio4


DMA modes: mdma0 mdma1 mdma2


UDMA modes: udma0 udma1 udma2 udma3 udma4 udma5 *udma6


AdvancedPM=yes: unknown setting WriteCache=enabled


Drive conforms to: unknown: ATA/ATAPI-2,3,4,5,6,7

* signifies the current active mode



# mount


rootfs on / type rootfs (rw)


/dev/root on / type ext4 (rw,noatime,errors=remount-ro,user_xattr,commit=6000,barrier=1,stripe=128,data=ordered,discard)
0 Kudos
1 Solution

@Zdenek: Was the system previouslly set to AHCI in the BIOS prior to the SSD swap?

View solution in original post

12 Replies
Community Manager

I've just upgraded my MacBook Pro 13 inch (mid 2009) with the same SSD disk and I am experiencing similar problem after waking it up from sleep mode. The effect is bit different - the system does not lose disk, but it begins freezing completely. The most interesting fact is that that this freezing is wave - like, I mean first 15-20 seconds I can't open any programm then next 30-35 secs - everything works fine, then effect accures again. Syslog does not show any errors. I also tried to switch memory dump to disk off, enabled/disabled TRIM, played with journalling mode, literally tried everything. Nothing helps despite reboot. After reboot system works absolutely fine with no signs of problem until the next sleep mode.


@Zdenek: Was the system previouslly set to AHCI in the BIOS prior to the SSD swap?

Community Manager

Hello CarpeDiem,

i try ahci and also ide emulation choices in bios without success.

I dont use swap in linux. I use hibernation to memory to 8GB RAM.


On previsous SSD OCZ Octane S2 SSD works fine with ahci, and without also ok.
Community Manager

I have 2x 120GB 520's in Raid 0.

I also have been expeiencing the sleep mode issues. Sometimes it comes outta sleep in 10 seconds, sometimes in 30. Most of the time, not at all.

I have an Asus Rampage 4 Extreme Motherboard. Swapping to a different SSD and it sleeps fine.....

Love to see this fixed.

Community Manager

I installed the new SSD a month ago (installing MS Windows 7 Prof x86 from scratch).


The BIOS hard drive controller is set as AHCI (using the last firmware), I already download the last Intel SSD ToolBox v 3.0.3 (the system tuner already said everything is ok) and the Intel Rapid Storage v10.8.0.1003,


Everything work fine, except that if I put my Asus T101MT on sleep, when I try to "wake up" the netbook after a few second showing a windows background come a Blue Screen and restart.

My netbook never failed before I replaced the original hard drive with the Intel SSD.

Community Manager

I am growing increasingly frustrated day after day with having to hard reboot my computer due to this sleep bug. With the price of SSD's dropping like the Red Sox, I'm about to RMA my 2 Intel's and solve my problem myself.

Just acknowledge this is an issue and humor me.

Community Manager

I just want to reopen this report to be lost in history. It's been a long time.

I am very indignant. Intel did not respond, as does the problem probably is not real. I expected some reaction, or a new firmware. I have no other choice. I'll come back drive to shop and for some time again forget the idea to buy something from Intel.


Bye Zdenek


Community Manager


I format from scratch (again) my Asus netbook T101MT hoping to fix the issue. Just install OS (Windows 7 professional x86 with all updates) and drivers but the resume from sleep continue.

Nearly 2 months after contacted Intel with the resume from sleep of the brand new SSD 520. No solution, neither at least a tip.

I always trusted Intel as reliable Co, but after this poor response I will rethink about Intel.

Community Manager

Hello all,

i want to share my HP elitebook 8460p with SSD 320 series problems.

Hard drive Specifications :

1. Model Number : INTEL SSDSA2BW160G3H

2. Model SERIES : INTEL SSD 320 SERIES 160 GB (show as 8 MB in intel SSD toolbox)

3. Serial Number : BAD_CTX 0000013F (shown in intel SSD toolbox)

4. Firmware : 4PC10365


1. Bluescreen error in windows vista enterprise 32 bit after automatic update in my company.

2. After restarting the notebook i got the following message in the startup "REBOOT AND SELECT PROPER BOOT DEVICE". My windows wouldn't even start.

3. I connect my SSD into another computer as secondary drive and boot to the windows. Check in the disk management, i found my harddrive is only 8 MB. Many of the forum called this "8 MB BUG". Note : my SSD harddrive is not shown in my computer.


1. HP software & driver : I downloaded "Intel Solid State Drive (SSD) Firmware Update" on website "[URL=""]" and trying to do install SP52887 directly from windows and it says "setup status : this harddrive model is not supported : ST380013AS" which is my first harddrive (not the SD). The most updated firmware, i try to install SP5508 and it says "update status : This harddisk model is not supported". SP52887 installer is also comes with disk images to update firmware from boot process, i also do this and it says "your harddrive is having the latest firmware, no upgrade is needed". So, i think i have no luck with HP software & driver.

2. Intel SSD toolbox : I downloaded Intel SSD toolbox from website "[URL=""][/URL][/URL]" and i cannot update to the latest firmware because of i have the latest firmware already. The only thing left is "SECURE ERASE" and it's the last thing i want to do because it will delete all the data in the SSD hard drive.


Anybody know how to fix SSD 320 series harddrive without secure erase it ?

New Contributor II

Rhyando wrote:

Hello all,

i want to share my HP elitebook 8460p with SSD 320 series problems.


Anybody know how to fix SSD 320 series harddrive without secure erase it ?

Look, I feel your pain. Having lost data due to a drive failure is not fun.

But copy/pasting your exact same question into 7 different threads is not increasing your chance of getting constructive feedback. On the contrary. It is considered spamming. And it is especially off topic for this thread, as it revolves around the 520 series, not the 320.

With that said, I have not heard of a confirmed working solution for your issue other than secure erasing it (and thereby definitively deleting all data). This guy ( represents a company that claims to be able to recover data from a 8MB'ed drive for an undisclosed amount of money (probably not cheap).

Please continue the 320 discussion here:

Community Manager

i'm sorry about the post that i wrote. I miss to read the 520 series in the topic above.. Because i think a lot of people already experienced this issue. I hope intel will heard this and make a solution as soon as possible. By the way, thank you for your suggestion. I will take a look of those website that you gave.

Community Manager


I had exactly the same problem on my elitebook 8440p

TL;DR; Only got round it by turning OFF the ATA drive lock. Sleep/resume then works fine. this does of course negate most of the security on the drive, making the whole thing bloody pointless. Whether it's a problem with this drives firmware, or the HP implementation of DriveLock, who knows. I do know that when my manager comes back and asks about how my trial of the drive went I can honestly say 'we can't buy this model for our staff". So come on Intel, I've given you a clue, get your finger out and investigate.

Long version:

BIOS is latest version.

Tried a fresh Win7 install with the bios in RAID MODE instead instead, no dice.

Tried turning off all the power saving on the drive (i.e. Drive power down = never), no dice

Last thing I will try in the future, is perhaps if I use the master password rather than the user password (for drivelock) it might bypass whatever bug is causing the problem (though I doubt it).