Solid State Drives (NAND)
Support for Issues Related to Solid State Drives based on NAND technology
This community is designed for sharing of public information. Please do not share Intel or third-party confidential information here.
3783 Discussions

Intel X25-V SSD RMA or Warranty?

Community Manager

Im a bit confused as to how to proceed.

I have a Intel X25-V 40GB SSD. I purchased it through TigerDirect back in March of 2010.

It appeasrs the drive just totally died on me. It will not post, and just hangs at the bios screen when connected.

``` It says it has a 3yr limited warranty, but I can not find where to check if its elegible. I can not return to TigerDirect, because its been 14months.

Is this a RMA type thing, or do I just need to buy a new drive?

So heres what happened, just in case this is something that can be fixed and someone may be able to help:

A couple days ago my PC starting really acting odd. sfc /scannow immediatly found issues it could no repair.

Even WEI scores for CPU and Disc were below normal. I ran it again and it came back to normal.

After many attempts to repair the system, I decided to just do a clean install.

At this point, it did show my disc as its laid out.

Disk0: Partiton 1 (100MB) -- Partition2 (37.2GB)

I deleted them, and created new, in preperation for a clean install. But it showed like this now:

Disk0: Partition1(0MB) unlallocated -- Partition2 (100Mb ) -- Partition 3(37.2GB) -- Partiton 4(0MB) unallocated.

This was really odd.

I let Windows just make it own partitions, and just a few seconds later it asked me to reboot .. and that was it.

The PC would hang at post (where it normally shows AHCI mode -- and lists all discs)

If I unplugged the Intel drive, post would resume as normal.

If I swapped SATA ports, post resumed as normal, until it gets to the Intel drive, then says "Port# (whatever port its in) No device detected" then hangs.

0 Kudos
4 Replies
Community Manager

Do you have another computer that you could test it in, to isolate it?

When you see the Intel AHCI screen, does it give a version number at top?

Motherboard model / BIOS version?

What firmware version is the SSD? (if you never upgraded it, it will have the factory version, which is listed on the drive's label)

Have you tried turning the SATA controller into 'IDE' mode in your motherboard BIOS options? Most BIOSes will show you the IDE detection screen on the POST screen; see if it's detected there.

If it were me, I'd change this. Then, I would use a HDAT2 CD (it's a free utility - download an iso and burn to cd) to check the SMART data (if it allows you to see the drive in IDE and it doesn't hang). The smart data might reveal some signs of a failing drive (i stress, might)

It might be worth attempting a secure erase on the drive if you are able to change the sata controller mode to IDE.

Finally, the 3-year warranty is manufacturer. Some retailers will honour the manufacturer warranty (i.e. handle the process for you) but due to competition and varying consumer laws by country, you'll find this is rare. If the retailer doesn't in your instance, you simply contact Intel Customer Support to RMA the drive (warranty/RMA.. really the same thing here).

Be aware that if you can detail what steps you have done to rule out other factors (your computer, power supply etc.) when contacting ICS, it will make the whole process quicker easier for everyone. Depending where you are, I think intel cover the cost to collect the failed drive and to deliver a replacement. This might vary around the world, but they're one of the best to deal with for warranty IMHO.


Community Manager

1st, TY for the reply.

Its Firmware is 02HD.

I re-Installed windows on a secondary SSD I have and all is well so far.

What I have tried so far with the Intel Drive:

Plugged it in on the new installation and Windows seen it.

I installed the Intel Tool Box to try a Secure Erase.

It said to delete Partitions on the drive before trying a SE, so I did.

It crashed the Disk Magager though, and I got errors in the event log. (2 related to the drives prot and 1 for the Disk Manager crash)

2nd try partitions were delted.

It then asked me to power cycle the drive. I did be removing the SATA plug, and replacing it.

At this point it asked which drive to Secure Erase, but would only refresh the screen if I selected the Intel Drive.

After closing the the toolbox, the drive disappeared and reappeared after a system reboot.

I then recreated partitons (`1 single partiton) and ran the toolboxs Full integrety check. It said the drive was OK.

Next, I tried cloning my drive over, but it would not boot. Just hung at the Windows splash screen throwing errors.

I tried to restore the same Image again, and this time Windows booted. Although some weird things are happening.

No new hardware found for the drive, yet it lists as it should in device manager.

WEI would not work properly etc.

At this point, I just plugged the other drive back in, and all was well.

The Intel Drive does show in post now however. So thats a good thing.

Im a bit confused because Im unsure if the Secure Erase even worked. It would only refresh, then drive was lost when toolbox was closed.

When I finally did get Windows to boot, I just have a lot of little oddities going on.

Ill try this all again, in IDE mode to see if that helps any.

Thank You.

Community Manager

Hmm, that firmware is considered pretty mature/stable I think, but that's not to say there could be a fault developing with the SSD.

At a guess, when you were trying to run Secure Erase from the SSD Toolbox, were you using the native Microsoft AHCI drivers from installation, or did you install the Rapid Storage Technology drivers?

Your experience sounds like the former (native drivers). The bit about partitions is normal (as a check to prevent people from secure erasing drives with data) but the bit about power cycling (when running in ACHI) is apparentlhy a known issue: see

I've encounted that last week actually. It was actually because I had the SSD in IDE mode and i couldn;'t secure erase because of the way windows requests security freeze on the drive. Not wanting to do the power-off trick, I reinstalled in AHCI mode, but used the native drivers. Once I installed the Intel RST drivers, it was all good.

Try the Intel RST 10.1 drivers (9.6 are stable too). I'm betting you'll be able to successfully erase it when they're used. Also ensure you've got the latest toolbox (which you probably have since it's a fresh install), only because I've seen the PDF release notes mentioning improvements to the secure erase feature.

Once you get it secure erased, it wouldn't hurt to do a few more full diag scans and refresh the smart data in the Intel SSD Toolbox.

Community Manager

OK this worked, Thank You.

Yes, I was using the Win7 AHCI driver. As well as trying in IDE mode with no luck.

After Installing the Intel AHCI driver, it still asked me to power cycle the drive but it worked.

Oddly, the first attempt went to 20% and said "Failed" This was a bit troubling but ...

I restarted the PC, and tried again, and it was successfull.

So far the drive seems to be doing just fine after the secure erase.

Still, I would love to what made it totally disappear from the bios and refuse to post in the first place.

None-the-Less, its doing just as well now as it always has.

Ill continue to monitor it for a few days and make sure its OK but it appears my issue has been resolved.

Thank you all for the help.