Wireless
Participate in insightful discussions regarding issues related to Intel® Wireless Adapters and technologies
7673 Discussions

Trying to install wireless drivers, says "The software package cannot be installed on your system"

Jasson
Beginner
538 Views

Recently Bought a Archer TXE75E and followed the download instructions here https://www.tp-link.com/us/support/download/archer-txe75e/ 

 

it just gives me intel driver installs:

 

BT-22.250.0-64UWD-Win10-Win11.exe

 WiFi-22.250.1-Driver64-Win10-Win11.exe

 

When I try to install I get a question about an upgrade and then an error with no error code:

error.pngupgrade.png

 

I found this thread: https://community.intel.com/t5/Wireless/I-want-to-know-how-to-fix-driver-installation-errors-When-it/td-p/704458 

 

Which suggested to do a clean install: https://www.intel.com/content/www/us/en/support/articles/000022173/wireless.html 

 

Windows build: Operating System: Microsoft Windows 10 Pro(10.0.19045 Build 19045)

 

Which now leaves me with no wireless nor bluetooth drivers because nothing I try to install works. Any help would be appreciated 

 

scan output attached.

0 Kudos
6 Replies
n_scott_pearson
Super User
534 Views

Here is a step-by-step process for performing the clean install:

  1. If you haven't already, download to your PC - but do not install just yet - the latest Bluetooth and Wireless driver packages for your adapter.
  2. Most important! Disable Internet access. Unplug Ethernet cable and/or disable wireless. Keep disabled until told to re-enable. Note this Wireless disable *must* be of type that will persist and stay disabled across reboots.
  3. From the Apps & Features applet, check for instances of Intel PROSet/Wireless Software and Intel Wireless Bluetooth. If none, skip forward to Step 6.
  4. Uninstall each instance of Intel PROSet/Wireless Software and/or Intel Wireless Bluetooth that is present. When prompted, choose to "Discard Settings".
  5. Manually reboot your computer, keeping Internet access disabled throughout.
  6. From the Device Manager applet, check the Network Adapters section for an entry for Intel Wi-Fi 6 AX210 and check the Bluetooth section for an entry for Intel Wireless Bluetooth that has an Intel driver associated with it. If neither is the case, skip forward to Step 12.
  7. Right click on the entry for Intel Wi-Fi 6 AX210 and uninstall it, choosing to (checkmark) Delete the driver software for this device.
  8. Repeat step 7 until the option to Delete the driver software for this device is not offered (greyed out).
  9. Right click on the entry for Intel Wireless Bluetooth and open its properties. If it has an Intel driver associated with it, then uninstall it, choosing to (checkmark) Delete the driver software for this device.
  10. Repeat step 9 until the option to Delete the driver software for this device is not offered (greyed out).
  11. Go back to Step 5.
  12. Install the downloaded Bluetooth driver package (my rule: always install Bluetooth first).
  13. Install the downloaded Wireless driver package.
  14. Manually shutdown and reboot your computer.
  15. Reenable Internet access. Restore Ethernet cable and/or reenable wireless.
  16. Test.

Note that it can sometimes take multiple uninstall (and reboot) cycles to clean out the old installations, so don't give up on the process. If you get to, say, 10 cycles, stop there and attempt the installation of the latest drivers.

Hope this helps,

...S

0 Kudos
Jasson
Beginner
493 Views

I do not think this worked. I followed the instructions, I have screenshots of the devices before and after the reboot. Either way I got the same error:

 

before the reset devicesat reste.png

 

and after reboot:

 

devices after reset.png

0 Kudos
n_scott_pearson
Super User
483 Views

Ah, I see the issue - and a confusing one it is. You say you have an Archer TXE75E - which utilizes Intel's Wireless-AX, WiFi 6E AX210 module - but this DM screenshot says that there is a Wireless-AC 3160 present. The 3160 is discontinued and the latest (22.250) driver packages do not include drivers for it. You end up with, well, garbage.

Do you by any chance have two wireless adapters installed? If so, you should remove the 3160 card from the system. If if cannot be removed from the system, you must disable it.

Next, when you plugged the TXE75E into the system, you plugged it into a PCIe x1 slot, right? It cannot be installed into any other size slot. The PCIe x1 slot looks like this:

n_scott_pearson_0-1718732680410.png

Also, you remembered to connect the cable from the back of the TXE75E to a motherboard USB header, right?

...S

0 Kudos
Jasson
Beginner
457 Views

ok I see. I did not install this but looking at my motherboard it seems one comes pre-installed. It is tightly in there an taking it out would require disassembling the entire PC to get to the MOBO ( ASRock Z270 KILLER SLI/AC) and actually breaking off the plastic protector around it.

 

I disabled it via bios in advanced setup (LAN receiver or something like that). I also disabled it on device manager and unplugged the ether etc. However it still managed to resurrect (maybe by the archer I put in?) itself and I still got the same error. I did install the card properly I believe: 

 

WhatsApp Image 2024-06-18 at 9.57.57 PM.jpeg

 

know of any other ways to disable it? or am I SOL

0 Kudos
n_scott_pearson
Super User
442 Views
You need to disable both the Wireless and Bluetooth components of the old card. Best if this is done from BIOS. Do this while new card is (temporarily) removed, so you are disabling the right components.
...S
0 Kudos
Jasson
Beginner
397 Views

Looks like it cannot be disabled: https://forum.asrock.com/forum_posts.asp?TID=5134&title=how-to-permanently-uefi-bios-disable-intel-adapter 

 

That is for a different version of the same generation of my MOBO and I followed the instructions and got the same frustrating results as the poster.

 

I will post to ASROCK forums and see if they can give me a solution.

0 Kudos
Reply