Community
cancel
Showing results for 
Search instead for 
Did you mean: 
idata
Community Manager
3,235 Views

BIOS in AHCI mode but AS SSD Benchmark shows drive in IDE mode

Hi,

 

I've an X25-M 160GB SSD in my Windows 7 notebook.

The BIOS is configured as AHCI mode but AS SSD Benchmark tells me that the drive is in IDE mode.

 

I've just installed the Intel INF-Update, no other drivers...

Is this normal?

 

Any ideas?

Thanks in advance,

Christian

Here are some screenshots:

http://img17.imageshack.us/img17/5735/devicemgr.jpg http://img17.imageshack.us/img17/5735/devicemgr.jpg

http://img200.imageshack.us/img200/3887/asssdo.jpg http://img200.imageshack.us/img200/3887/asssdo.jpg

Tags (2)
7 Replies
idata
Community Manager
198 Views

This is absolutely normal, I have the same, no problems at all.

idata
Community Manager
198 Views

Looking at your SATA controller it appears you do not have the Microsoft AHCI driver installed. If that is the case, then until there is firmware supporting Intel AHCI drivers, you will have to either schedule TRIM or run it manually via the Toolbox Optimizer.

AS SSD shows it as an ATA device and that is normal. If you run Crystal Disk Info, you will see SATA/300.

idata
Community Manager
198 Views

look thoroughly before posting http://img17.imageshack.us/img17/5735/devicemgr.jpg http://img17.imageshack.us/img17/5735/devicemgr.jpg

Oops sorry I understand what you mean

standard MS drivers looks like this in device manager http://www.pvle.be/wp-content/2009/09/DeviceManager02_thumb.png http://www.pvle.be/wp-content/2009/09/DeviceManager02_thumb.png

but picture from the first post means that windows is using same windows driver as ms, it's just used the name of controller from INF, installed by intel chipset installation utility. The intel driver is installed only by Intel Matrix Storage or Intel Rapid Storage, otherwise windows is using default ms driver, playing only with names of the controller. Am I wrong?

idata
Community Manager
198 Views

I don't know if he has the Microsoft AHCI driver installed. As I said before, it looks like he does not. He may have installed the Intel Storage Manager--I just don't know. All he has to do is look at the driver/driver details and tell us.

idata
Community Manager
198 Views

Dear all,

thank you for your answers.

Correct, CrystalDiskInfo 3 tells me that the drive is running at SATA/300.

I'd installed the Matrix Storage Manager before but I unstalled it.

Currently only the chipset inf-update is installed.

The drivers details from the AHCI controller:

Is this the correct driver with the TRIM support when firmware is available?

Best regards,

Christian

idata
Community Manager
198 Views

msahci.sys is the correct driver for native trim support in Win 7.

idata
Community Manager
198 Views

Yes, the msahci.sys is the correct driver to pass TRIM automatically without the need for using Optimizer. You could install an Intel driver and run the Optimizer on schedule or manually. It is expected in the near future Intel will release its own driver to pass TRIM automatically, until then, only the Microsoft AHCI driver will pass TRIM automatically.

Reply