Intel® oneAPI Math Kernel Library
Ask questions and share information with other developers who use Intel® Math Kernel Library.
7000 Discussions

Intel MKL libraries with remote StatET connection crashes R?


Hi everyone,

Is anyone using the Intel MKL math libraries with R, and accessing it remotely using Eclipse + StatET plugin?

I am trying to connect to R 2.15.3 running on Linux from a Windows box running Eclipse 3.8.2 and the StatET plugin for R . Have been using this setup for months without issue. That is until recently, when we recompiled R with the Intel MKL optimized numeric libraries, and are running into problems, but only through StatET.

If I run a simple matrix operation like "crossprod(1:4)" in a local R session on the server, it returns fine. On a more complex operation, it is noticeably faster (one test went from 86 seconds down to 35 seconds), which is what we were hoping to see by using these libraries. But if I start a remote session via Eclipse/StatET, and run the same command, it kills the entire remote R session.

In the log files on the server I see the error"Intel MKL FATAL ERROR: Cannot load or". I've compared LD_LIBRARY_PATH in both the local and remote sessions, and can't find any differences -- both have entries pointing to the Intel MKL directories.

> Sys.getenv("LD_LIBRARY_PATH")
[1] "/usr/lib/jvm/java-1.6.0-openjdk-"

I've fiddled with numerous settings and environment variables, tried reinstalling StatET components on the server without success. I don't know if this is a StatET problem, an Intel MKL problem, or a local configuration problem.

Any suggestions would be appreciated.

Some additional detail that shows up in the error log as soon as I issue the "crossprod(1:4)" statement that causes the crash:

java.vendor=Oracle Corporation
BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=en_US
Command-line arguments: -os win32 -ws win32 -arch x86_64
Error Mon Oct 07 11:24:51 EDT 2013
Communication error detail. Send:
MainCmdC2SList ():
<ITEM i="0">
options= 0xc1000001
java.rmi.UnmarshalException: Error unmarshaling return header; nested exception is:
at sun.rmi.transport.StreamRemoteCall.executeCall(Unknown Source) at sun.rmi.server.UnicastRef.invoke(Unknown Source) at java.rmi.server.RemoteObjectInvocationHandler.invokeRemoteMethod(Unknown Source) at java.rmi.server.RemoteObjectInvocationHandler.invoke(Unknown Source) at com.sun.proxy.$Proxy15.runMainLoop(Unknown Source) at de.walware.rj.server.client.AbstractRJComClient.runMainLoop( at de.walware.rj.server.client.AbstractRJComClient.answerConsole( at at at at$ at$ at at at at at$0( at$ Caused by: at Source) ... 18 more

0 Kudos
4 Replies


Can you confirm if both MKL and R are installed on Remote machine? Also, can you make sure you set mkl variables on remote machine?


0 Kudos

Hi Sridevi,

Thanks for the response.  R and MKL are installed on the remote machine.  It may not have been clear in my original message, but I can log in to the remote machine, run a local R session on that server, and successfully run commands that use MKL (I see multiple cores engaged, performance speed up).  But when I run the same command through a remote R session, R crashes.

I have compared the LD_LIBRARY_PATH variables between both sessions (local vs remote), and both include the same MKL directories.  I tried explicitly sourcing "/opt/intel/mkl/bin/ intel64" from within the remote R session to force any variables that may have not been set, and R still crashes when I run my test command.  Is there something else I can do to check that variables are set properly?

The only error I see in the log file for the remote R session after it crashes is: "Intel MKL FATAL ERROR: Cannot load or" 

0 Kudos

We were eventually able to get it to work by using statically linked libraries rather than dynamic.


0 Kudos

Hey OP I too use Intel MKL math libraries with R and i face same problem as OP  ,, can some one reply to this post ?

0 Kudos