Media (Intel® Video Processing Library, Intel Media SDK)
Access community support with transcoding, decoding, and encoding in applications using media tools like Intel® oneAPI Video Processing Library and Intel® Media SDK
Announcements
The Intel Media SDK project is no longer active. For continued support and access to new features, Intel Media SDK users are encouraged to read the transition guide on upgrading from Intel® Media SDK to Intel® Video Processing Library (VPL), and to move to VPL as soon as possible.
For more information, see the VPL website.

Initial use of h264 encoder directshow

Martin_Vanputten
Beginner
251 Views
Hi everyone,

I have noticed something a bit strange, and am not quite sure how to fix it, although its not mission critical but more of an annoyance.

So what happens is the h264 encoder filter is used within an application but if copied to a new machine, say to intall that application... the filter does not work the first time. I've found that opening graphedit... pulling in the filter... and then loading the property pages does something and there after the application can then utilize the filter.

Can anybody think of any reason for this?

Cheers.
0 Kudos
1 Reply
Petter_L_Intel
Employee
251 Views
Hi Martin,

Not sure what the issue may be. There should be no issue doing what you describe. The filter does not depend on a specific registry entry. If the is no filter registry entry, it will be created when first executing the filter.

Was the correct filter registered successfully on the new system before running the application?

Can you provide some more info on what happens "when it does not work". Do you get an error message?

Regards,
Petter
0 Kudos
Reply