Nios® II Embedded Design Suite (EDS)
Support for Embedded Development Tools, Processors (SoCs and Nios® II processor), Embedded Development Suites (EDSs), Boot and Configuration, Operating Systems, C and C++
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
12435 Discussions

Win7-Problem with NIOS-II debugger, can't start gdbserver

Altera_Forum
Honored Contributor II
1,598 Views

I have the following problem:  

I'm running the (32bit) Quartus 11.0sp1 and Eclipse built tools for the NIOS-II on a Win7-machine with 64bit. 

An additional standalone-programmer for Quartus 12.0sp2 (64bit) is installed.  

 

Programming both .sof/jic files and NIOS-II .elf-files works.  

 

What doesn't work is: Debugging in the eclipse environment.  

 

Error-message is: "Error starting gdbserver - see console for details"  

But there are no details in the console! I already tried to disable all firewall and virus scanners, but the problem still exists.  

 

And I have to admit, that I do not really know what this message means. Is it a configuration problem of eclipse? Can I setup the gdbserver somehow? Is it a problem with the JTAG-Connection? I also tried to manually debug the software, but I didn't get far. The pdf "nios-II command-line tools" didn't help me much. 

 

I'm really a bit lost now. Where can I find further informations what's really wrong? What shall I do?  

 

Any help is appreciated!  

 

Thanks 

Andreas
0 Kudos
4 Replies
Altera_Forum
Honored Contributor II
306 Views

This may be the problem that is fixed by running Eclipse "as administrator" . When you launch it, use right-click on your mouse and you will see this option. 

 

hope this helps
Altera_Forum
Honored Contributor II
306 Views

Sorry for not answering so long, I was away on holiday. 

 

But I already tried this option and unfortunately it didn't help. Wether starting it with admin-rights, nor running eclipse from an admin-account.  

Both did not solve the problem!
Altera_Forum
Honored Contributor II
306 Views

I discovered that if I open a "Nios II 14.0 Command Shell" and run eclipse-nios2.exe from the resulting Cygwin bash shell, then Eclipse is able to start gdbserver and run the debugger in the "Nios II Debug" perspective correctly. Previously, I had been using the "Nios II 14.0 Software Build Tools for Eclipse" shortcut installed in the Start menu by the Altera installer and encountered the gdbserver problem that you reported.

Altera_Forum
Honored Contributor II
306 Views

I've seen the same error here with 13.1 on a 64bit linux system. 

I'm not going to run any of the tools as root there. 

AFAICT most of the progress messages that might help you work out where things are failing are discarded by the GUI system. 

I got code running (without gdb - I'm not worried about gdb) by running 'make download-elf' and fixing $PATH and $LD_LIBRARY_PATH until it worked.
Reply