Nios® V/II Embedded Design Suite (EDS)
Support for Embedded Development Tools, Processors (SoCs and Nios® V/II processor), Embedded Development Suites (EDSs), Boot and Configuration, Operating Systems, C and C++
Announcements
All support for Intel NUC 7 - 13 systems has transitioned to ASUS. Read latest update.

Problems with kernel >= 4.x

Altera_Forum
Honored Contributor II
1,119 Views

Hi, 

 

I currently trying to replace my kernel with version 3.17 with a newer 

one with version greater than 4.x.  

I tried several versions but I am facing some problems and maybe anybody 

else had the same issues and know a fix. 

 

1. Problem  

The bridges are renamed from hps2fpga to br0 and so on. I am using the 

standard sockit device tree for the Terasic DE1SoC. 

Is this common that the old names are gone? And are the bridges now 

enabled and disabled automatically? 

 

2. Problem  

I cannot configure the fpga by writing the rbf file to the /dev/fpga0 device.# cat /sys/class/fpga_manager/fpga0/state 

power off 

It looks like the FPGA is not powered?! 

 

Big thx in advance 

gandi
0 Kudos
0 Replies
Reply