Nios® V/II Embedded Design Suite (EDS)
Support for Embedded Development Tools, Processors (SoCs and Nios® V/II processor), Embedded Development Suites (EDSs), Boot and Configuration, Operating Systems, C and C++
Announcements
All support for Intel NUC 7 - 13 systems has transitioned to ASUS. Read latest update.
12578 Discussions

error trying to build mmu-less uClinux

Altera_Forum
Honored Contributor II
912 Views

I've seen others getting this error but none of the solutions seem to help me. I'm trying to get an mmu-less uClinux kernel running for one of the de2 example machines. 

 

When I do 

$make vendor_hwselect SYSPTF=<path> 

 

I get the error  

make[3]:Entering directory '/root/nios2-linux/linux-2.6' 

make[4]: *** No rule to make target 'hwselect'. Stop. 

 

followed by the rest of the sub-makes exiting. 

 

make menuconfig worked just fine before this, and the prebuilt toolchain seems to be working. I have both ../linux-2.6 and ../uClinux-dist on the test-nios2 branch. 

 

Thanks very much for the help!
0 Kudos
1 Reply
Altera_Forum
Honored Contributor II
229 Views

I figured out my problem. I had tried to build the kernel before I switched to the test-nios2 branch, and for some reason that seems to have prevented it from building after I switched. I just deleted my nios2-linux directory, and redid everything from the start making sure to checkout the test-nios2 branch before I tried building anything.

0 Kudos
Reply