Wireless
Participate in insightful discussions regarding issues related to Intel® Wireless Adapters and technologies
7500 Discussions

Killer Networks Service not running

pelikan
Beginner
5,490 Views

I cannot use Killer Intelligence Center: "Service Not Running"

 

- Intel Killer AX1675 (AX210, PCIe), aftermarket

- KillerPerformanceSuite_35.23.826_Win10-11_x64

- Killer Intelligence Center from Windows Store

- Windows 11 Pro 23H2, fresh install

        - Core Isolation, Memory Integrity: On

- AM5 Plattform

 

Order of Installation:

1. KPS

2. KIC

3. Bluetooth driver

 

In services.msc:

- Killer Network Service, Startup type: automatic

 

In Task Manager, Startup apps:

- Killer Intelligence Center: enabled

 

Now, I can start the Killer Network Service manually in services.msc and the Killer Network Center works for 5s until the service gets disabled again automatically.

 

I followed the steps  in [1] and reinstalled the driver and KIC, but the problem remains.

 

Any ideas?

 

BTW: Most if not all "Related Topics"  links  in Killer support articles are dead.

[0] Updating the Intel® Killer™ Performance Suite In Microsoft Store*  - all dead

[1] How to Perform a Clean Installation to Solve Most Intel® Killer™ Performance Suite Issues  - all dead

[2] How to Stop Intel® Killer™ Control Center updates from the Microsoft Store*  - all dead

 

I get redirected to support main page: https://www.intel.com/content/www/us/en/support.html

 

 

0 Kudos
26 Replies
DeepWaters
Beginner
829 Views

@pelikan were you/Intel/Asus able to resolve this? Having the exact same issue, which makes the Killer card useless to me.

0 Kudos
pelikan
Beginner
833 Views
No, I didn't bother contacting ASUS.
0 Kudos
DeepWaters
Beginner
823 Views

Thanks for all the troubleshooting you did, and appreciate the quick reply. I did contact Asus; will update here if it's resolved.

0 Kudos
SeventhWinds
Beginner
803 Views

I never even heard back from Intel community on this. I made a post almost 2 months ago.

 I don't believe the Intel cards are any good, avoid at all costs if you value your Internet speeds.
I purchased a 2.5Gbps PCI ethernet from realtek and it's plug and play, just works! no weird issues like 200Mbps / 2.2Gbps.
No bloat ware. 

 Intel software always errors out and says the service is not running however if you search services and enable it manually it works for a whole 5 seconds but no changes you make actually save.

 I've giving up and bought an external capture card to replace the internal since I'm forced to use a realtek 2.5Gbps ethernet pci card in that particular slot.

0 Kudos
hoonywise
Novice
602 Views

I am having the exact same issue as the OP, although my motherboard is Asrock x670E Taichi. I downloaded the latest drivers and package suite 35.24.1177 from Intel as this having this suite installed allowed me to download the Killer Control Center from Windows Store.  Any previous versions will not allow downloading from the Windows Store.  Something about Win 10 apps needing to be exfat or fat32 formatted.

 

Now that I have Killer Control Center at least installed (but services not running), I will try to uninstall the 35.24.1177 and install previous versions, starting with Asrock provided one from 2022 perhaps that will work.

0 Kudos
hoonywise
Novice
467 Views

Just wanted to chime in.  Using old drivers provided by Asrock (3.1122.3146), Killer Intelligence Center will not install at all.  So I am stuck now.

Reply