Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Marián__VooDooMan__M
New Contributor II
152 Views

2015 Update 1 crash log

Jump to solution

Greetings,

see attached crash log.

sensitive informations were replaced by "XXX".

TIA!

0 Kudos
1 Solution
Vitaly_S_Intel
Employee
153 Views

Marian shared symbol file for problematic binary with us which helped to root cause original crash issue.

Marian, thank you again for your help!

View solution in original post

24 Replies
Peter_W_Intel
Employee
120 Views

Thank you for this valuable report, and I have escalated this to our engineering team.

I may contact you via private message if necessary. Thank you, again

Marián__VooDooMan__M
New Contributor II
120 Views

My pleasure.

I am not 100% sure, but this crash of devenv occurs only when I in the middle of Vtune analyse in runtime of my application press button "pause" (in VTune GUI) and then after while "resume". It goes okay, but this crash occurs when Vtune is processing analysed data before results are displayed in VTune GUI.

Peter_W_Intel
Employee
120 Views

Thank you for additional info:-)

Marián__VooDooMan__M
New Contributor II
120 Views

Marián "VooDooMan" Meravý wrote:

My pleasure.

I am not 100% sure, but this crash of devenv occurs only when I in the middle of Vtune analyse in runtime of my application press button "pause" (in VTune GUI) and then after while "resume". It goes okay, but this crash occurs when Vtune is processing analysed data before results are displayed in VTune GUI.

Actually, now I had similar crash without pausing analysis. So please disregard my previous post.

Bernard
Black Belt
120 Views

@Marian

Is there any information about the type of crash like: APP Hang or Access Violation?

Marián__VooDooMan__M
New Contributor II
120 Views

iliyapolak wrote:

@Marian

Is there any information about the type of crash like: APP Hang or Access Violation?

No. The VTune integration into MSVC IDE just displayed window with attached crash log, and offered me to send it by e-mail. Since on this machine I don't have e-mail client, I just did copy-paste the report window content into attached file on this forum topic. Then I clicked "don't send" and that GUI window immediately closed itself with MSVC 2013 IDE too.

Marián__VooDooMan__M
New Contributor II
120 Views

It just seems VTune has its own handling of access violation by displaying informations, instead of standard Windows's crash message/dump/debugging offer.

Bernard
Black Belt
120 Views

Marián "VooDooMan" Meravý wrote:

It just seems VTune has its own handling of access violation by displaying informations, instead of standard Windows's crash message/dump/debugging offer.

Yes it seems to be true. I am having also problems with VTune which is crashing VS 2013 debugger. Few times I ran VS 2013 under windbg hoping that exception will be caught by the debugger , but I was disappointed deeply when windbg broke on some managed language exceptions. Then I came to conclussion that various exceptions are handled by the ICC or VTune themselves.

Bernard
Black Belt
120 Views

>>>The VTune integration into MSVC IDE just displayed window with attached crash log>>>

I looked at attached log and was not able to find any clue about the error reason. My last hope was raw stack data(which can contain KiExceptionDispatcher exception data) but no symbols were resolved.

Marián__VooDooMan__M
New Contributor II
120 Views

iliyapolak wrote:

>>>The VTune integration into MSVC IDE just displayed window with attached crash log>>>

I looked at attached log and was not able to find any clue about the error reason. My last hope was raw stack data(which can contain KiExceptionDispatcher exception data) but no symbols were resolved.

Do not be afraid, Intel engineers should be able to understand that crash log, because if they weren't, they would not implement window with such crash log offering sending it be e-mail.

Anyway thank you for your effort.

Bernard
Black Belt
120 Views

Yep I know that Intel VTune developers will solve that issue.

Marián__VooDooMan__M
New Contributor II
120 Views

Running standalone VTune, the new crash log from GUI is attached as "crash_log2.txt"

EDIT: oops, I forgot to obfuscate sensitive informations by "XXX". attaching "crash_log3.txt"

Bernard
Black Belt
120 Views

Can you open that dmp file with windbg and run analyze -f  windbg will walk VTune call stacks and search for the exception context if present the it will be displayed.

Bernard
Black Belt
120 Views

I meant this dump file 

Path: C:\Users\XXX\amplxe-log-vdmn\2014-11-05-Wed-20-54-50-121.amplxe-gui.exe\crash.4820.dmp
Marián__VooDooMan__M
New Contributor II
120 Views

It looks like incorrect event handling in VTune GUI using wxWidgets library.

0:000> !analyze -f
*******************************************************************************
*                                                                             *
*                        Exception Analysis                                   *
*                                                                             *
*******************************************************************************

Use !analyze -v to get detailed debugging information.

*** ERROR: Symbol file could not be found.  Defaulted to export symbols for amplxe_qfagentminidump_core_1.15.dll - 
*** ERROR: Symbol file could not be found.  Defaulted to export symbols for amplxe_boost_thread_1.55.dll - 
*** ERROR: Symbol file could not be found.  Defaulted to export symbols for amplxe_gen_helpers_core_2.21.dll - 
*** ERROR: Symbol file could not be found.  Defaulted to export symbols for amplxe_tbb.dll - 
*** ERROR: Symbol file could not be found.  Defaulted to export symbols for amplxe_dicerresolver_core_2.6.dll - 
*** ERROR: Symbol file could not be found.  Defaulted to export symbols for amplxe_dicerengine_core_2.19.dll - 
*** ERROR: Symbol file could not be found.  Defaulted to export symbols for amplxe_client_1.5.dll - 
*** ERROR: Symbol file could not be found.  Defaulted to export symbols for amplxe_wx_helpers_core_1.22.dll - 
Probably caused by : wxmsw28u_vc_amplxe_2.8.1222.dll ( wxmsw28u_vc_amplxe_2_8_1222!wxEventLoop::Dispatch+43 )

Followup: MachineOwner
---------

0:000> !analyze -v
*******************************************************************************
*                                                                             *
*                        Exception Analysis                                   *
*                                                                             *
*******************************************************************************


FAULTING_IP: 
+73006d005f0063
00000000`00000000 ??              ???

EXCEPTION_RECORD:  ffffffffffffffff -- (.exr 0xffffffffffffffff)
ExceptionAddress: 0000000000000000
   ExceptionCode: 80000003 (Break instruction exception)
  ExceptionFlags: 00000000
NumberParameters: 0

CONTEXT:  0000000000000000 -- (.cxr 0x0;r)
rax=0000000000002716 rbx=000000000013fc60 rcx=0000000005d0c620
rdx=000000000013fc50 rsi=0000000005317770 rdi=00000000001a461c
rip=00007ff8f9dc208a rsp=000000000013fbf8 rbp=000000000013fc50
 r8=00000000029bee60  r9=00000001401f51e8 r10=00000001401e6b68
r11=0000000000000000 r12=0000000000000001 r13=00000000029bd0a0
r14=0000000005dcc760 r15=0000000005dcc760
iopl=0         nv up ei pl zr na po nc
cs=0033  ss=002b  ds=002b  es=002b  fs=0053  gs=002b             efl=00000246
user32!NtUserGetMessage+0xa:
00007ff8`f9dc208a c3              ret

FAULTING_THREAD:  00000000000004d4

DEFAULT_BUCKET_ID:  STATUS_BREAKPOINT

PROCESS_NAME:  amplxe-gui.exe

ERROR_CODE: (NTSTATUS) 0x80000003 - {EXCEPTION}  Breakpoint  A breakpoint has been reached.

EXCEPTION_CODE: (HRESULT) 0x80000003 (2147483651) - One or more arguments are invalid

APP:  amplxe-gui.exe

ANALYSIS_VERSION: 6.3.9600.17237 (debuggers(dbg).140716-0327) x86fre

PRIMARY_PROBLEM_CLASS:  STATUS_BREAKPOINT

BUGCHECK_STR:  APPLICATION_FAULT_STATUS_BREAKPOINT

LAST_CONTROL_TRANSFER:  from 00007ff8f9dc2055 to 00007ff8f9dc208a

STACK_TEXT:  
00000000`0013fbf8 00007ff8`f9dc2055 : 00000000`00000001 00000000`053b1a60 00000000`05dcc760 00000000`001a461c : user32!NtUserGetMessage+0xa
00000000`0013fc00 00000000`0213aad3 : 00000000`001a461c 00000000`05dcc760 00000000`001a461c 00000000`0213aa81 : user32!GetMessageW+0x25
00000000`0013fc30 00000000`02222ae0 : 00000000`001a461c 00000000`05317770 00000000`0013fd30 00000000`0213aa3d : wxmsw28u_vc_amplxe_2_8_1222!wxEventLoop::Dispatch+0x43
00000000`0013fcc0 00000000`021ea620 : 00000000`05c6c4c8 0000041a`00000489 00000000`00000094 ffffffff`fffffffe : wxmsw28u_vc_amplxe_2_8_1222!wxEventLoopManual::Run+0x90
00000000`0013fd10 00000000`02055229 : 00000000`001a461c 00000000`6d67caf9 00000000`05303148 00000001`40000000 : wxmsw28u_vc_amplxe_2_8_1222!wxAppBase::MainLoop+0x80
00000000`0013fd80 00000000`020f29f2 : 00000000`00000000 00000000`05317770 00000000`00000000 00000000`00000000 : wxmsw28u_vc_amplxe_2_8_1222!wxEntryCleanup+0x259
00000000`0013fe00 00000001`40126687 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : wxmsw28u_vc_amplxe_2_8_1222!wxEntry+0x122
00000000`0013feb0 00007ff8`fa0516ad : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : amplxe_gui!eil1::IDebugCallback::OnCustomStoppingDebug+0x11aeb7
00000000`0013ff60 00007ff8`fbd94409 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : kernel32!BaseThreadInitThunk+0xd
00000000`0013ff90 00000000`00000000 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : ntdll!RtlUserThreadStart+0x1d


STACK_COMMAND:  ~0s; .ecxr ; kb

FOLLOWUP_IP: 
wxmsw28u_vc_amplxe_2_8_1222!wxEventLoop::Dispatch+43
00000000`0213aad3 85c0            test    eax,eax

SYMBOL_STACK_INDEX:  2

SYMBOL_NAME:  wxmsw28u_vc_amplxe_2_8_1222!wxEventLoop::Dispatch+43

FOLLOWUP_NAME:  MachineOwner

MODULE_NAME: wxmsw28u_vc_amplxe_2_8_1222

IMAGE_NAME:  wxmsw28u_vc_amplxe_2.8.1222.dll

DEBUG_FLR_IMAGE_TIMESTAMP:  544c3329

FAILURE_BUCKET_ID:  STATUS_BREAKPOINT_80000003_wxmsw28u_vc_amplxe_2.8.1222.dll!wxEventLoop::Dispatch

BUCKET_ID:  APPLICATION_FAULT_STATUS_BREAKPOINT_wxmsw28u_vc_amplxe_2_8_1222!wxEventLoop::Dispatch+43

ANALYSIS_SOURCE:  UM

FAILURE_ID_HASH_STRING:  um:status_breakpoint_80000003_wxmsw28u_vc_amplxe_2.8.1222.dll!wxeventloop::dispatch

FAILURE_ID_HASH:  {c4e35aee-2d9c-6627-195c-ca48aae079af}

Followup: MachineOwner
---------

 

Bernard
Black Belt
120 Views

Thanks for posting !analyze command output. It seems that breakpoint status was caught by debugger. by looking at the stack it seems that this thread could be UI thread which is processing probably a message loop. exception breakpoint is not much of help here so we must wait for VTune devs answer.

Vitaly_S_Intel
Employee
120 Views

Hi all!

Just to record - the issue is related to using compile option /debug:inline-debug-info and specific compiler version - 14.0 Update 6. Marian confirmed it is not reproduced neither with 13.0.1 nor with 15.0.

Marián__VooDooMan__M
New Contributor II
120 Views

Greetings,

I made a typo in our private conversation. Correct is: It is not reproducible with 15.0.1 (I.e. Update 1). It is related to 14.0 Update 6.

Peter_W_Intel
Employee
120 Views

I got surprise it said this was a 2015 U1 crash report. Anyway, it is good that it is not reproducible in 2015 U1:-)  

Vitaly_S_Intel
Employee
45 Views

15.0.1 is compiler version :)

Reply