Community
cancel
Showing results for 
Search instead for 
Did you mean: 
tassel__pierre
Beginner
71 Views

Analysis doesn't start (no cpu usage)

Hello everybody,

I'm not an expert so i already apologies if i'm doing an obvious mistake.

I try to analyse the performance of a programm for different compilation method's.

So i tried to do a profile-guided optimization with intel's compiler (following this tutorial : https://software.intel.com/en-us/code-samples/intel-compiler/intel-compiler-features/ProfileGuidedOp... ) and the performance worsted. I then tried to launch a vTune analysis (advanced-hotspot) to see what happend but it never ended-up.

When i launch the programm without vTune he run perfectly, but with vtune the processors doesn't even start.

No CPU usage

Of course i've waited for a longer period it's just for the screenshot.

Here is how i compiled the programm :

icpc sources/minimax_graph.cpp -std=c++11 -prof-dir=../bin -prof-gen -O3 -o test.out                           # bin is a directory where is stored the profile generated, originially the compiled programm are stored in this folder


cat ../input/j2.txt | ./../bin/intel_profil_O3.out                        # generate the profile

icpc sources/minimax_graph.cpp -std=c++11 -prof-dir=../bin -prof-use -O3 -o test.out                              # compil and use the profil

If you want the source code, here he is : https://raw.githubusercontent.com/ingambe/ter/master/sources/minimax_graph.cpp (is .h file is here : https://raw.githubusercontent.com/ingambe/ter/master/sources/minimax_graph.h )

the vtune command is the following : amplxe-cl -collect advanced-hotspots ./test.out < input/j1.txt

I've added to path Intel compiler and vtune using :

source /opt/intel/compilers_and_libraries/linux/bin/compilervars.sh intel64 and source /opt/intel/parallel_studio_xe_2018/psxevars.sh intel64

I have an intel processor (i7-4710HQ), i use Ubuntu 18, here is the result of the uname -a command :

Linux pierre-PC 4.15.0-24-generic #26-Ubuntu SMP Wed Jun 13 08:44:47 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

I've reboot my computer but i still have this issue.

Here is the result of : icpc --version
icpc (ICC) 18.0.2 20180210
Copyright (C) 1985-2018 Intel Corporation.  All rights reserved.

and amplxe-cl --version :

Intel(R) VTune(TM) Amplifier 2018 Update 2 (build 551022) Command Line Tool
Copyright (C) 2009-2018 Intel Corporation. All rights reserved.

Thank for the help,

Have a good day ! :)

0 Kudos
0 Replies
Reply