Analyzers
Support for Analyzers (Intel VTune™ Profiler, Intel Advisor, Intel Inspector)
Announcements
This community is designed for sharing of public information. Please do not share Intel or third-party confidential information here.
4682 Discussions

Assertion failed: pytrace_collector710

Wood-Patrick__Mark
348 Views

After capturing perf data using the command:

     /home/tools/intel/vtune_amplifier_2018.1.0.535340/bin64/amplxe-cl -collect hotspots -run-pass-thru=--no-altstack <my binary>

I'm getting:

amplxe: Error: Assertion failed: pytrace_collector710: thread_manager_result == tpss_thread_manager_op_err_ok || thread_manager_result == tpss_thread_manager_op_err_acquired : Cannot acquire tsd for current thread (tid = 42407), result = 8. Please contact the technical support. 
amplxe: Error: Assertion failed: pytrace_collector710: thread_manager_result == tpss_thread_manager_op_err_ok || thread_manager_result == tpss_thread_manager_op_err_acquired : Cannot acquire tsd for current thread (tid = 42412), result = 8. Please contact the technical support. 
amplxe: Error: Assertion failed: pytrace_collector710: thread_manager_result == tpss_thread_manager_op_err_ok || thread_manager_result == tpss_thread_manager_op_err_acquired : Cannot acquire tsd for current thread (tid = 42417), result = 8. Please contact the technical support. 
amplxe: Error: Assertion failed: pytrace_collector710: thread_manager_result == tpss_thread_manager_op_err_ok || thread_manager_result == tpss_thread_manager_op_err_acquired : Cannot acquire tsd for current thread (tid = 42422), result = 8. Please contact the technical support. 
amplxe: Collection stopped.
amplxe: Using result path `/home/scratch.mwoodpatrick_inf/fsa/fsf_trees/Cuda_Test/450489367/output_12_31_19__0434/r000hs'

What do these errors mean? Any suggestions what I'm doing wrong, the report is generated & viewable. I'm still learning my way around the viewer so I'm not sure if they make sense yet but at first glance they don't look unreasonable, is there some documentation that will help me understand what this error means

Operating system and version: CentOS release 6.8 (Final)

Tool version: vtune_amplifier_2018.1.0.535340

Compiler version: gcc-5.4.0

0 Kudos
1 Reply
Vladimir_R_Intel
Employee
348 Views

Hi Mark,

please install the latest and greatest VTune (currently it is 2020 Gold), this place is already fixed.

Reply