Community
cancel
Showing results for 
Search instead for 
Did you mean: 
DongWang-BJTU
New Contributor I
770 Views

Can't find CPU/FPGA interaction tab in Vtune 2020 update 1

Jump to solution

Hi, I am using Vtune profiler v2020 update 1 with Intel FPGA OpenCL SDK, and I am trying to read the profiled data with vtune. However, I could not get the CPU/FPGA interaction tab as described in the documents.

This is what I got:

fpga.PNG

 

This is what is illustrated in the documents:

doc.PNG

As compared above, there is no CPU/FPGA interaction tab in my tool.   How could I get it displayed ?

The vtune is running in driverless mode with the following env set:

sudo sh -c "echo 0 > /proc/sys/kernel/perf_event_paranoid"
sudo sh -c "echo 0 > /proc/sys/kernel/yama/ptrace_scope"

The Intel FPGA OpenCL SDK is v20.1 and OS is Ubuntu 16.04.

0 Kudos
1 Solution
Dmitry_R_Intel1
Employee
683 Views

Actually VTune runs this aocl profile automatically underneath so everything should work correctly out of the box if you run FPGA analysis specifying host executable as an application to launch. 

One known limitation is that VTune currently doesn't support -x option and assumes aocx file can be found in the current directory. Maybe this is the reason of the problems. If not - I would advice to try the just released VTune 2020 U2 version and if it still won't help we'll have to dig it more.

View solution in original post

10 Replies
AthiraM_Intel
Moderator
703 Views

Hi,


Thanks for reaching out to us.

 

VTune 2020 Update 2 is available now, you could try the same on the new update and check whether the issue still persists.


Could you please confirm whether the application is running in FPGA?

 

Please let us know that you are following the correct procedure as in the documentation?

 

We will investigate on this from our end also.



Dmitry_R_Intel1
Employee
698 Views

From the picture it looks like information about FPGA kernels wasn't actually collected and FPGA view became not applicable.

Was the application run successfully under profiling? I see that execution time is very low, just a few ms - is it expected? Did you see any errors in the Collection Log?

If you used 'AOCL profiler' as the profiling data source your device-side code needs to be compiled with the '-profile' option - was it done?

DongWang-BJTU
New Contributor I
687 Views

The problem has been solved thanks to the help with an AE.

One have to manually run "aocl profile ./host -x file.aocx" to generate the profile.mon and profile.json before using the Vtune.

This information has not been included in the user's manual.

Dmitry_R_Intel1
Employee
684 Views

Actually VTune runs this aocl profile automatically underneath so everything should work correctly out of the box if you run FPGA analysis specifying host executable as an application to launch. 

One known limitation is that VTune currently doesn't support -x option and assumes aocx file can be found in the current directory. Maybe this is the reason of the problems. If not - I would advice to try the just released VTune 2020 U2 version and if it still won't help we'll have to dig it more.

View solution in original post

AthiraM_Intel
Moderator
630 Views

Hi,


Glad to know that your issue got resolved.

Since VTune 2020 U2 version is available now , you could try the same on the new release and let us know if the issue still persists.


Thanks


AthiraM_Intel
Moderator
593 Views

Hi,


Have you tried out the same in VTune 2020 U2 release? Please let us know if the issue still persists.


Thanks


DongWang-BJTU
New Contributor I
577 Views

Hi, I have not tried v2020.2 yet, will update as soon as I have time to try this version.

AthiraM_Intel
Moderator
562 Views

Hi,


Thanks for the update. We would be waiting to hear back from you.






AthiraM_Intel
Moderator
525 Views

Hi,


We would be glad to hear an update from you.


Thanks


AthiraM_Intel
Moderator
495 Views

Hi,


We have not heard back from you, we wont be monitoring this thread. Please raise a new thread if you have further issues.


Thanks.


Reply