Community
cancel
Showing results for 
Search instead for 
Did you mean: 
84 Views

Cannot locate debugging symbols for file `/tmp/amplxe-tmp-lab/xxxxx/

Hi,

I am trying to profile an application using the remote analysis workflow as mentioned in this link.

https://software.intel.com/en-us/node/496398#46F7A60C-C2A4-4EEA-9460-BC33B892DA8F

When i try to the run the profiler using GUI as well as command line, i am getting these warning messages:

amplxe: Using result path `/home/xxxx/vtune_trial/xxxxxx/r002hs'

amplxe: Executing actions 16 % Resolving information for `bash'               

amplxe: Warning: Cannot locate debugging symbols for file `/tmp/amplxe-tmp-xxxxx/modules.ssh_xxxx@xxxxxxxxxxxxxx/bash/d79a947d06958e7826d15a5c78bfaa05/bash'.

amplxe: Executing actions 17 % Resolving information for `ls'                 

amplxe: Warning: Cannot locate debugging symbols for file `/tmp/amplxe-tmp-xxxx/modules.ssh_xxxx@xxx-xxxxxxxxxxxxxxx/ls/fa97c59cc414e42d4e0e853ddf5b4745/ls'.

amplxe: Executing actions 17 % Resolving information for `sed'                

amplxe: Warning: Cannot locate debugging symbols for file `/tmp/amplxe-tmp-xxxxxxxxx/modules.ssh_xxx@xxxxxxxxxxxxxxxxxxxxxxxxxx/sed/89ecfdcf755d11e6f73fbb7fed9248d0/sed'.

amplxe: Executing actions 50 % Generating a report

 

Can anyone tell me what is going on here? The analysis report doesn't have much hotspot details.

Thanks

Sri   

0 Kudos
1 Reply
Peter_W_Intel
Employee
84 Views

There are no debugging info for utilities bash, ls, sed - they have no symbol info in binaries.

You can ignore these warning message...you need to pay attention on hotspots which located on your modules. If reported your modules have no debugging info, you need to check if you added "-g" to build applications? then added option "-search-dir=$dir1" ($dir1 is the location of your binaries in host) to collect performance data.