Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Fan_Xp_
Beginner
115 Views

Cannot start Amplifier

Hi,

I installed vtune_amplifier_xe_2013 on a 32-bit Ubuntu 12.04. But everytime I run it like this

/opt/intel/vtune_amplifier_xe_2013/bin32/amplxe-cl,   or 

/opt/intel/vtune_amplifier_xe_2013/bin32/amplxe-gui

it will give me some error, like this

terminate called after throwing an instance of 'std::runtime_error'

  what():  locale::facet::_S_create_c_locale name not valid

 

I googled a little, but cannot find any solutions.

Do you guys have any idea? Any help will be appreciated.

 

Thanks

-Xuepeng

0 Kudos
9 Replies
Bernard
Black Belt
115 Views

Bernard
Black Belt
115 Views

Anyway that error should be solved by VTune devs.

Fan_Xp_
Beginner
115 Views

Thanks for your reply, I read your post and stack overflow, but...what should I do? 

iliyapolak wrote:

Anyway that error should be solved by VTune devs.

David_A_Intel1
Employee
115 Views

Hi Fan:

If you are using a purchased copy of the VTune Amplifier XE, please submit an issue at Intel® Premier Support.  Include in your problem report a copy of the bug report file created by executing 'amplxe-feedback -create-bug-report report.zip'.

If you are using a non-commercial version, please post the information in a message to me (see the "Send Author a Message" link in the upper right portion of this message).

Bernard
Black Belt
115 Views

Fan Xp. wrote:

Thanks for your reply, I read your post and stack overflow, but...what should I do? 

Quote:

iliyapolak wrote:

Anyway that error should be solved by VTune devs.

 

Sorry I should have written that best option in your case is either waiting for the response from VTune engineers like @Peter and @Mr. Anderson  or contact Intel Premier Support.

David_A_Intel1
Employee
115 Views

For everyone's benefit, Fan and I exchanged some information and it turn out to be an incomplete locale setting.  Once Fan added:

export LC_ALL="en_US.UTF-8"

Everything started working. :)

Sumedh_N_Intel
Employee
115 Views

I have found that in case the above locale setting doesn't work for you, another setting to try is LC_ALL=C. 

 

Bernard
Black Belt
115 Views

@MrAnderson

Thank you for informing us:)

Caesar
Beginner
115 Views

Hurray!

Same problem here and solved it with: export LC_ALL="en_US.UTF-8"

Reply