Community
cancel
Showing results for 
Search instead for 
Did you mean: 
komradebob
Beginner
37 Views

Clicking on Function Name in sampling hotspot by process doesn't open source code

possible noob question here...

I'm running through the tutorial for vtune, have gotten the gsample2a example compiled and the initial run done.

When I try clicking on the function name in the 'Most Active Functions In Your Application' tab, I get nothing. No new tab, window, or the like opens.

Running on Linux, X.

Ideas, pointers, whatnot?
sceen shot
0 Kudos
6 Replies
Peter_W_Intel
Employee
37 Views

I can't see picture (don't know why). I recommend to read this article - it may help.

Regards, Peter
Peter_W_Intel
Employee
37 Views

Now I can see this picture, it seems that is not "inline" related issue!

The issue is - can't go to source view. Are you sure source available? Locked by other process?

Can you reproduce this problem by using Sampling Wizard?

Exit VTune Analyzer and reenter it to solve this problem?

Click on "View All Processes" to find hot module, click on hot function - what happens?

Clean / Change vtune workspace? (If some vtune data are damaged!)

Regards, Peter

komradebob
Beginner
37 Views

Yes, the source is available. No, it is not locked by another application. (Though if it were, I'd expect an error...)

The problem happens every time I run vtune.

This is a totally fresh installation. Happens for myself and every other user.


Peter_W_Intel
Employee
37 Views

Have you tried suggestions I posted last time?

Is this problem repeatable with other applications?

If this issue is for specific application, please submit a ticket to https://premier.intel.com with test case.

Thank you.

-Peter
komradebob
Beginner
37 Views

Not sure which suggestion you are referring to. I'm running through the VTune tutorial from the 'Vtune Getting Started - Linux' document. I was just handed Vtune earlier in the week for the first time.

Exiting vtune and restarting didn't solve it.

The problem happens even after deleting the gsexample directory and copying it back from the original, freshly installed, location.

If I go to 'View All Processes' I get a tab showing all the procs on the box.

'Clean' is greyed out from the Project menu.

I get the same result if I try to get to the source after starting up via the sampling wizard as the First Use Wizard


Peter_W_Intel
Employee
37 Views

Sorry that I might not clarify it clearly. Here are my further suggestions.

1. Couldsome data be destroyed in"vtune workspace"?When you enter VTune Analyzer, can you select other new folder for "vtune workspace"? Does itsolvethe problemafter doing sampling data collection?

2. Can you select other example application (e.g. vtunedemo) to create a new activity? Same problem?

3. Was it caused by GUI? So you can use vtl command to verify -
a. cd /opt/intel/vtune/samples/gsexample
b. vtl activity -c sampling -app "./gsexample2a, datafile.txt" run
c. vtl view -gui ; Can you see source afterdrilling downprocesses report, threads report, modules report, hotspots report?

Regards, Peter

Reply