Analyzers
Support for Analyzers (Intel VTune™ Profiler, Intel Advisor, Intel Inspector)
4641 Discussions

Collection failed: Cannot run VTune on Ubuntu 20.04 on large programs

amcc
Novice
845 Views

After running a user-sampling mode hotspot analysis with vtune -collect hotspots on a large Fortran code, the analyser throws the following error:

vtune: Error: [Instrumentation Engine]: Source/pin/injector_u/loadercommands.cpp: NotifyOnMiniloaderFailure: 689: Injector: caught unexpected signal 11 while running miniloader on file /usr/bin/dash
vtune: Collection failed.
vtune: Internal Error

 

VTune was installed under Intel oneAPI, and the code was compiled with symbols with Intel Fortran compiler.

Weirdly, VTune runs seamlessly on the furnished example (`matrix`) and on minimal working examples written in Fortran.

 

The output of vtune-self-checker is available here , and insmod-sep -q returns

pax driver is loaded and owned by group "vtune" with file permissions "660".
socperf3 driver is not correctly loaded.
sep5 driver is not correctly loaded.

socwatch driver is loaded and owned by group "vtune" with file permissions "660".

vtsspp driver is loaded and owned by group "vtune" with file permissions "660".

 

I should also remark that the code in question could be analysed without any trouble with amplxe-gui, installed with Intel Parallel Studio.

 

I would deeply appreciate some help on the subject.

Thank you in advance.

Labels (1)
0 Kudos
10 Replies
AthiraM_Intel
Moderator
783 Views

Hi,


Thanks for reaching out to us.


You could try to build drivers using the build-driver script present in {vtune_intallation_directory}/sepdk/src 


./build-driver


If building the drivers succeeds, install them manually with the insmod-sep script:


cd <install_dir>/sepdk/src


./insmod-sep -r -g <group>


where <group> is the group of users that have access to the driver.


Please find below link for more detailed documentation on building drivers:


https://software.intel.com/content/www/us/en/develop/documentation/vtune-help/top/set-up-analysis-ta...


If the issue still persists, please let us know.


Thanks.


amcc
Novice
740 Views

Hello,

 

Thank you very much for your answer.

Unfortunately, I still cannot get vtune to work after executing the commands that you so suggested. I registered the modules with the group vtune, to which my user belongs.

The self-checker now says

The system is ready to be used for performance analysis with Intel VTune Profiler.
Review warnings in the output above to find product limitations, if any.

but the program fails with the same error as above.

 

If it helps, I am launching vtune-gui from the command line with my normal user account (which belongs to vtune group).

 

Do you have any ideas on what is going on?

AthiraM_Intel
Moderator
707 Views

Hi,


Could you please let us know if there is any changes in the selfchecker logs after running the steps and share the selfchecker log file?


Also share your Vtune version.



Thanks.


AthiraM_Intel
Moderator
674 Views

Hi,


We haven't heard back from you. Could you please give us an update?


Thanks


amcc
Novice
663 Views

Hello,

 

Sorry for taking so long to get back to the topic. The version of VTune Profiler that I am using is:

Intel(R) oneAPI VTune(TM) Profiler 2021.3.0 (build 616728)

 

The main differences that I can spot on the log files of the self-checker utility are the following:

 

1) Essentially all error messages that shown in the old self-checker log disappear, in particular, the ones suggesting the installation of Intel Sampling Drivers.

 

2) The following warning is not shown: "vtune: Warning: Cannot locate debugging information for the Linux kernel. Source-level analysis will not be possible. Function-level analysis will be limited to kernel symbol tables. See the Enabling Linux Kernel Analysis topic in the product online help for instructions.".

 

Also, according to the self-checker, The system is ready to be used for performance analysis with Intel VTune Profiler. Unfortunately, even though I can run the program, the collection still fails as mentioned in the original post.

 

Thank you for your help.

AthiraM_Intel
Moderator
653 Views

Hi,


Thanks for sharing the details. We are checking on it internally.

Meanwhile could you please share the new selfchecker log file with us. It would be helpful to debug the issue.


Thanks


amcc
Novice
637 Views

Hi,

 

Here it is!

 

Thank you for your support!

AthiraM_Intel
Moderator
618 Views

Hi,


Thanks for sharing the log file. We are checking on it internally and will get back to you soon.


Could you please share sample reproducer and the commands you used to try out the same from our end.


Thanks


AthiraM_Intel
Moderator
593 Views

Hi,


We have not heard back from you. Could you please give us an update?


Thanks.


AthiraM_Intel
Moderator
570 Views

Hi,


We have not heard back from you, so we will close this inquiry now. If you need further assistance, please post a new question.


Thanks.


Reply