Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Minh-Nhut_Hong
Beginner
35 Views

Disable source panel

Hello,

I am having problem with VTune Amplifier XE 2011 - Source View panel while attempting to analyze Locks and Waits. Source view panel is disable. I have all the source compiled with debug mode. I also have 'Project Properties' -> Search Directories points to proper source directory. I am using build 119041, non-commercial version.

Any suggestions?

Thanks,
Nhut
0 Kudos
3 Replies
Peter_W_Intel
Employee
35 Views

Hi,

Please use latest product VTune Amplifier XE 2011 Update 2 to verify again.

First at all, please ensure that sync-object dropped in your source file. Secondary, have you specified directoriesfor binary file, symbol file? (I mean if your source file can not be found, the tool will display assembly code if binary is available)

If the problem persists on, please submit issue to https://premier.intel.comwith result directory, associated module file, source file for investigating in detail.

Thanks, Peter
Minh-Nhut_Hong
Beginner
35 Views

Peter,

Thank you for your response.

I tried the demo program tachyon_find_hotspots. Source view panel works fine with this one. Later I found out that all of my source programs were complied with -g and -gstabs options. I took the-gstabs one out. I am able to Source view panel now.

Nhut
Peter_W_Intel
Employee
35 Views

"-gstab" is not supported, since address is not real function entry :-)