Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Ron_Reeder
Beginner
119 Views

Eclipse crashing with Exit code=1

I have Vtune 9.1 installed. Attempting to run vtlec script that invokes eclipse, that uses jvm.

Starts ok.

Select 'First Use' button.

Select vtunesample.

Click Finish - Then crashes:

JVM terminated. Exit code=1 /usr/java/jre1.6.0_18/bin/java -Dosgi.splashLocation=/opt/intel/eclipsepackage/3.2.1/eclipse/plugins/com.intel.sdp.primary_2.0.4/splash.bmp -Dosgi.sharedConfiguration.area=/opt/intel/vtune/bin/../shared/eclipse/configuration -jar /opt/intel/eclipsepackage/3.2.1/eclipse/startup.jar -os linux -ws gtk -arch x86 -launcher /opt/intel/eclipsepackage/3.2.1/eclipse/eclipse -name Eclipse -showsplash 600 -exitdata 84800b -product com.intel.sdp.primary.product -perspective com.intel.vtune.shell.tuningPerspective -vm /usr/java/jre1.6.0_18/bin/java -vmargs -Dosgi.splashLocation=/opt/intel/eclipsepackage/3.2.1/eclipse/plugins/com.intel.sdp.primary_2.0.4/splash.bmp -Dosgi.sharedConfiguration.area=/opt/intel/vtune/bin/../shared/eclipse/configuration -jar /opt/intel/eclipsepackage/3.2.1/eclipse/startup.jar

Note, I switched to new 32bit jvm, after reading another thread on hear suggesting to move to latest 32bit from sun.

[l0309612@houw0759 gsexample]$ /usr/java/jre1.6.0_18/bin/java -version java version "1.6.0_18" Java SE Runtime Environment (build 1.6.0_18-b07) Java HotSpot Server VM (build 16.0-b13, mixed mode)

[l0309612@houw0759 gsexample]$ rpm -qi jre Name : jre Relocations: /usr/java Version : 1.6.0_18 Vendor: Sun Microsystems, Inc. Release : fcs Build Date: Thu 17 Dec 2009 06:16:00 PM CST Install Date: Thu 04 Mar 2010 03:27:00 PM CST Build Host: jdk-lin-1586 Group : Development/Tools Source RPM: jre-1.6.0_18-fcs.src.rpm Size : 50610917 License: Sun Microsystems Binary Code License (BCL) Signature : (none) Packager : Java Software URL : http://java.sun.com/ Summary : Java Platform Standard Edition Runtime Environment Description : The Java Platform Standard Edition Runtime Environment (JRE) contains everything necessary to run applets and applications designed for the Java platform. This includes the Java virtual machine, plus the Java platform classes and supporting files. The JRE is freely redistributable, per the terms of the included license.

[l0309612@houw0759 gsexample]$ env |grep jre

OTHER_JVM_BINDIR=/usr/java/jre1.6.0_18/bin/

I also copied the vtune 'sample' directory under my home directory - updated permisions .. So, I've tried:

- java that comes with intel vtune install

- java from sun

- sample directory moved to my home.

0 Kudos
10 Replies
Ron_Reeder
Beginner
119 Views

Oh, additional information.

Following error messages occur while Eclipse is running:

[l0309612@houw0759 gsexample]$ /opt/intel/vtune/bin/vtlec

(Intel SDP:26297): Gtk-WARNING **: Unable to locate theme engine in module_path: "clearlooks",
java: config_n_control.cpp:582: signed int TBSInitDriver(): Assertion `dwConfigID == 0' failed.

(eclipse:26164): Gtk-WARNING **: Unable to locate theme engine in module_path: "clearlooks",
[l0309612@houw0759 gsexample]$ /opt/intel/vtune/bin/vtlec

(Intel SDP:26538): Gtk-WARNING **: Unable to locate theme engine in module_path: "clearlooks",
java: config_n_control.cpp:582: signed int TBSInitDriver(): Assertion `dwConfigID == 0' failed.

(eclipse:26398): Gtk-WARNING **: Unable to locate theme engine in module_path: "clearlooks",

Peter_W_Intel
Employee
119 Views

Here are my comments -

1. Use "root" privilege to install the product on your home directory (local driver). Don't do copy (move) folderand set access permission

2. Ensure that vtune driver can work -testit by using, 1) lsmod | grep vtune; 2)"vtl activity -d 10 -c sampling run".

3. If vtune driver is not loaded, please go vtune/vdk/src, do 1)./build-driver 2)insmod-vtune 3)install-boot-script --install

4. For JVM issue to run vtlec, please refer to other thread - http://software.intel.com/en-us/forums/showthread.php?t=65848(don't know why there is an space in URL, sorry)

Regards, Peter

Ron_Reeder
Beginner
119 Views

Thanks for the reply Peter.

I've been working on this off & on for the past several days.

Getting:

1 Error creating new thread errno: 12
*** pthread_create failed with 'not enough memory' !!!
*** process /opt/java/jre1.6.0_18/bin/java EXITING !!!

1. Installed 'locally' on server with Intel CPU's.

1.b Copied /opt/intel/eclipsepackage (NFS mount) to /opt/vtune/eclipsepackage (local mount)

2. Installed Sun java 1.6

3. start vtlec from 'workspace' directory.

4. Environment variables:

OTHER_JVM_BINDIR=/opt/java/jre1.6.0_18/bin/

VTUNE_GLOBAL_DIR=/data/isilon/vtune/global_data

5. Modified eclipse.ini

cat /opt/vtune/eclipsepackage/3.2.1_0/eclipse/eclipse.ini
-vmargs
-Xms1024m
-Xmx1024m
6. cd into workspace dir then start

cd /home/l0309612/vtune_workspace

/opt/vtune/bin/vtlec

It had been working through 'First Use' and only crashing when attempting Call Graph.

Now it's crashing on 'First Use' again.

VM terminated. Exit code=12
/opt/java/jre1.6.0_18/bin/java
-Xms1024m
-Xmx1024m
-jar /opt/vtune/eclipsepackage/3.2.1_0/eclipse/startup.jar
-os linux
-ws gtk
-arch x86
-launcher /opt/vtune/eclipsepackage/3.2.1_0/eclipse/eclipse
-name Eclipse
-showsplash 600
-exitdata 430006
-product com.intel.sdp.primary.product
-perspective com.intel.vtune.shell.tuningPerspective
-Xms512M
-Xmx1024M
-Dosgi.splashLocation=/opt/vtune/eclipsepackage/3.2.1_0/eclipse/plugins/com.intel.sdp.primary_2.0.4/splash.bmp
-Dosgi.sharedConfiguration.area=/opt/vtune/bin/../shared/eclipse/configuration
-vm /opt/java/jre1.6.0_18/bin/java
-vmargs
-Xms1024m
-Xmx1024m
-jar /opt/vtune/eclipsepackage/3.2.1_0/eclipse/startup.jar

Peter_W_Intel
Employee
119 Views

Please see my comments on your each step:

1. It seems that you installed VTune Analyzer on local drive. Why did you copied othereclipsepackage to vtune directory? I suggest to use eclipsepackage come with VTune Analyzer, ifit is not default, please set environment (like as "export OTHER_ECLIPSE_BIN=/opt/intel/eclipsepackage/3.2.1_0/eclipse/eclipse")

2. I suggest not use latest Sun java 1.6. Maybe you can try Sun JVM 5.0 32-bit (even for your 64bit OS). Latest Sun java 1.6 updateshave not been tested for our product.

4. (Thisshould be step 3). It seems ok, but ensure /data/isilon/vtune/global_da is not NFS

5. (This should be step 4) Why did you change vmargs? Is it root-cause? (I saw - *** pthread_create failed with 'not enough memory')

step 3 and step 6, delete contents in old workspace if you use vtlec to start and select old workspace. Last time error inforemained might affect on this run. Or you can select new workspace on local driver.

Hope it helps.

Regards, Peter

Ron_Reeder
Beginner
119 Views

Ok,

Uninstalled vtune & reinstalled.

- Rebuilt the driver.

- Installed java 5.0 21

Pretty much the same thing.

I rm -fR workspace

directory, after each run (also kill 'listener process')

errout:

1 Error creating new thread errno: 12
*** pthread_create failed with 'not enough memory' !!!
*** process /opt/java/jre1.5.0_21/bin/java EXITING !!!

Eclipse crash window:

JVM terminated. Exit code=12
/opt/java/jre1.5.0_21/bin/java
-Dosgi.splashLocation=/opt/intel/eclipsepackage/3.2.1_0/eclipse/plugins/com.intel.sdp.primary_2.0.4/splash.bmp
-Dosgi.sharedConfiguration.area=/opt/intel/vtune/bin/../shared/eclipse/configuration
-jar /opt/intel/eclipsepackage/3.2.1_0/eclipse/startup.jar
-os linux
-ws gtk
-arch x86
-launcher /opt/intel/eclipsepackage/3.2.1_0/eclipse/eclipse
-name Eclipse
-showsplash 600
-exitdata 30000
--launcher.XX:MaxPermSize 256m
-vm /opt/java/jre1.5.0_21/bin/java
-product com.intel.sdp.primary.product
-perspective com.intel.vtune.shell.tuningPerspective
-vm /opt/java/jre1.5.0_21/bin/java
-vmargs
-Dosgi.splashLocation=/opt/intel/eclipsepackage/3.2.1_0/eclipse/plugins/com.intel.sdp.primary_2.0.4/splash.bmp
-Dosgi.sharedConfiguration.area=/opt/intel/vtune/bin/../shared/eclipse/configuration
-jar /opt/intel/eclipsepackage/3.2.1_0/eclipse/startup.jar

Peter_W_Intel
Employee
119 Views

Please let me know your system info, and vtune version: `uname -a`, `/opt/intel/vtune/bin/vtl version`

Thanks!

Ron_Reeder
Beginner
119 Views

l0309

612@login3 ~]$ uname -a
Linux login3 2.6.18-128.el5 #1 SMP Wed Jan 21 10:41:14 EST 2009 x86_64 x86_64 x86_64 GNU/Linux

[l0309612@login3 ~]$ /opt/intel/vtune/bin/vtl version
VTune Performance Analyzer 9.1 for Linux* build 401
Copyright (C) 2000-2009 Intel Corporation. All rights reserved.

Installed Intel Software Development Products:

VTune Performance Analyzer 9.1 for Linux*
Build: 401

Peter_W_Intel
Employee
119 Views

I have same VTune Analyzer version & environment as you have, but no problem to run vtlec -

[root@NHM02 peter]# cat /etc/redhat-release
Red Hat Enterprise Linux Server release 5.3 (Tikanga)
[root@NHM02 peter]# uname -a
Linux NHM02 2.6.18-128.el5 #1 SMP Wed Dec 17 11:41:38 EST 2008 x86_64 x86_64 x86_64 GNU/Linux

[root@NHM02 peter]# /opt/intel/vtune/bin/vtl version
VTune Performance Analyzer 9.1 for Linux* build 401
Copyright (C) 2000-2009 Intel Corporation. All rights reserved.

Installed Intel Software Development Products:

VTune Performance Analyzer 9.1 for Linux*
Build: 401

1. I installed VTune Analyze version 9.1 Update 7 in local drive, with installation type - Full Install
2. The user should see new Eclipse* package has been installed -
[root@NHM02 3.2.1_4]# pwd
/opt/intel/eclipsepackage/3.2.1_4
3. The user should see new JRE installed -
[root@NHM02 bin]# pwd
/opt/intel/eclipsepackage/3.2.1_4/jrockit-R27.2.0-jre1.5.0_10/bin

Review your error report/message from the top of this thread -
"JVM terminated. Exit code=1 /usr/java/jre1.6.0_18/bin/java -" : that is to use wrong JRE (may not be tested!!!)
And I don't know what default Eclipse* that you are using, so you may do
4a. Use "export OTHER_ECLIPSE_BIN=/opt/intel/eclipsepackage/3.2.1_4/eclipse/eclipse"
4b. Use "export OTHER_JVM_BINDIR=/opt/intel/eclipsepackage/3.2.1_4/jrockit-R27.2.0-jre1.5.0_10/bin"

5. Run "/opt/intel/vtune/bin/vtlec" - the problem shouldhave gone!

Note that we usually try default Jrockit first, then Sun's JRE.

Regards, Peter

Ron_Reeder
Beginner
119 Views

Ok,

Reinstalling - 'Full Install'

It wants to install a _different_ version of eclipse than what you have, i..e

/opt/intel/eclipsepackage/3.2.1_1/eclipse

Froum your notes, you have:
/opt/intel/eclipsepackage/3.2.1_4

How is that possible?

.... I guess we are time shifted by 1/2 a day....

I went ahead and uninstalled/re-installed again...
Built the driver & loaded it....

Pointed to the 'jorockit' jvm.
Removed workspace directories.
kill any vtlistenerd processes.
Still, no joy - Interestingly, it's yet anothe eclipse package ... 3.2.1_1 - but not the one you have...

stderr messages:
1 Error creating new thread errno: 12
*** pthread_create failed with 'not enough memory' !!!
*** process /opt/intel/eclipsepackage/3.2.1_1/jrockit-R27.2.0-jre1.5.0_10/bin/java EXITING !!!

[1]+ Done /opt/intel/vtune/bin/vtlec


Eclipse crash window:

JVM terminated. Exit code=12
/opt/intel/eclipsepackage/3.2.1_1/jrockit-R27.2.0-jre1.5.0_10/bin/java
-Dosgi.splashLocation=/opt/intel/eclipsepackage/3.2.1_1/eclipse/plugins/com.intel.sdp.primary_2.0.4/splash.bmp
-Dosgi.sharedConfiguration.area=/opt/intel/vtune/bin/../shared/eclipse/configuration
-jar /opt/intel/eclipsepackage/3.2.1_1/eclipse/startup.jar
-os linux
-ws gtk
-arch x86
-launcher /opt/intel/eclipsepackage/3.2.1_1/eclipse/eclipse
-name Eclipse
-showsplash 600
-exitdata e8000
-product com.intel.sdp.primary.product
-perspective com.intel.vtune.shell.tuningPerspective
-vm /opt/intel/eclipsepackage/3.2.1_1/jrockit-R27.2.0-jre1.5.0_10/bin/java
-vmargs
-Dosgi.splashLocation=/opt/intel/eclipsepackage/3.2.1_1/eclipse/plugins/com.intel.sdp.primary_2.0.4/splash.bmp
-Dosgi.sharedConfiguration.area=/opt/intel/vtune/bin/../shared/eclipse/configuration
-jar /opt/intel/eclipsepackage/3.2.1_1/eclipse/startup.jar

Peter_W_Intel
Employee
119 Views

"Still, no joy - Interestingly, it's yet anothe eclipse package ... 3.2.1_1 - but not the one you have..."

[Peter] It doesn't matter. For example, if I didn't install eclipse* package from VTune Analyzer before, eclipse package name should be "3.2.1" under "/opt/intel/eclipsepackage". Second time, if I uninstalled/reinstalled the product, and "3.2.1" still remained, so "3.2.1_1" name will be used, ... , next time "3.2.1_2", "3.2.1_3"... will be used.

"stderr messages:
1 Error creating new thread errno: 12
*** pthread_create failed with 'not enough memory' !!!
*** process /opt/intel/eclipsepackage/3.2.1_1/jrockit-R27.2.0-jre1.5.0_10/bin/java EXITING !!!"

[Peter] You and I use same software, OS version.
I think that this problem is not VTune Analyzer relevant, it is possible -
1) Too many processes in your system, to shutdown some?
2) Increase memory, or try software on other machine?
3) Ask other people on Linux Forum, e.g. access http://www.linuxforums.org/forum/?

I have provided you all clues, that I know.

Regards, Peter
Reply